This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 446401 - Bluetooth headset still not working the fedora way
Bluetooth headset still not working the fedora way
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: bluez-gnome (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 10:01 EDT by Nicolas A. Corrarello
Modified: 2008-06-04 07:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 07:53:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas A. Corrarello 2008-05-14 10:01:57 EDT
Description of problem:
When trying to pair a Nokia Headset with the gnome-bluetooth applet, you don't
get asked for a pin and then it tries to open the headset with obex to browse
for files. I'm able to pair it manually, and add manually the entry for the
headset in .asoundrc, the device get recognized but still no sound.
Version-Release number of selected component (if applicable):
[root@hermes ~]# rpm -qa | grep blue
bluez-utils-3.30-2.fc9.i386
bluez-libs-3.30-1.fc9.i386
bluez-utils-alsa-3.30-2.fc9.i386
gnome-bluetooth-libs-0.11.0-3.fc9.i386
bluez-utils-cups-3.30-2.fc9.i386
gnome-bluetooth-0.11.0-3.fc9.i386
bluecurve-icon-theme-8.0.2-1.fc9.noarch
bluez-gnome-0.25-1.fc9.i386


How reproducible:
Very
Steps to Reproduce:
Try pairing a bluetooth headset in gnome.

Then try to pair it with hcitool, you get asked for the password but still,
you're unable to see the device.

Try creating the file ~/.asoundrc with the following content
pcm.bluetooth {
   type bluetooth
   device 00:11:22:33:44:55
}
as instructed in the bluez wiki. You see the device but can't play sound
(permissions are correct, and audio service is running)


  

Additional info:
Works like a charm with btsco, but not included in the distro. Headset is Nokia
BH-205
Comment 1 Ondrej Vasik 2008-05-19 09:12:28 EDT
Reassigning to bluez-gnome.
Comment 2 Bastien Nocera 2008-05-19 09:25:15 EDT
(In reply to comment #0)
<snip>
> Steps to Reproduce:
> Try pairing a bluetooth headset in gnome.

And how do you do that?

> Then try to pair it with hcitool, you get asked for the password but still,
> you're unable to see the device.

See the device where?

> Try creating the file ~/.asoundrc with the following content
> pcm.bluetooth {
>    type bluetooth
>    device 00:11:22:33:44:55
> }
> as instructed in the bluez wiki. You see the device but can't play sound
> (permissions are correct, and audio service is running)

Errors anywhere? What's the output of:
rpm -qa "*bluez*"
Comment 3 Nicolas A. Corrarello 2008-05-19 11:29:40 EDT
>> Steps to Reproduce:
>> Try pairing a bluetooth headset in gnome.

>And how do you do that?

Well, I click on the gnome-bluetooth-applet, browse for a device, find my
headset, dbl-click on it, and then a gnome alert pops that says that it cannot
browse the obex://MAC-OF-THE-BT-HEADSET/
Ok, I know that if I click on browse device It should be a browseable device,
but is there another gui-based way of pairing with a bluetooth device such as this?

>> Then try to pair it with hcitool, you get asked for the password but still,
>> you're unable to see the device.

>See the device where?

Well I'm able now if I pair it with hcitool to see it as a Pulseaudio sound
device. Still I don't get sound on it.

Sorry about the versions, 
[root@hermes ~]# rpm -qa | grep blue
bluez-utils-3.30-2.fc9.i386
bluez-libs-3.30-1.fc9.i386
bluez-utils-alsa-3.30-2.fc9.i386
gnome-bluetooth-libs-0.11.0-3.fc9.i386
bluez-utils-cups-3.30-2.fc9.i386
gnome-bluetooth-0.11.0-3.fc9.i386
bluecurve-icon-theme-8.0.2-1.fc9.noarch
bluez-gnome-0.25-1.fc9.i386

[root@hermes ~]# rpm -qa | grep obex
openobex-1.3-11.fc9.i386
obex-data-server-0.3.1-1.fc9.i386
gnome-vfs2-obexftp-0.4-6.fc9.i386

I've another bug about the obex file transfer, is BZ #446403
Comment 4 Bastien Nocera 2008-06-04 07:53:13 EDT
(In reply to comment #3)
> >> Steps to Reproduce:
> >> Try pairing a bluetooth headset in gnome.
> 
> >And how do you do that?
> 
> Well, I click on the gnome-bluetooth-applet, browse for a device, find my
> headset, dbl-click on it, and then a gnome alert pops that says that it cannot
> browse the obex://MAC-OF-THE-BT-HEADSET/
> Ok, I know that if I click on browse device It should be a browseable device,
> but is there another gui-based way of pairing with a bluetooth device such as
this?

No, because we don't support audio yet in the UI[1], but if you just access the
device (ie. try to use it) while it's in pairing mode/discoverable, the
bluetooth applet will pop up for the pin.

[1]: it's on the TODO list:
https://fedoraproject.org/wiki/Features/Bluetooth#Handsfree_headsets_.28phone_use.29_and_Headphones_.28Music.29

> >> Then try to pair it with hcitool, you get asked for the password but still,
> >> you're unable to see the device.
> 
> >See the device where?
> 
> Well I'm able now if I pair it with hcitool to see it as a Pulseaudio sound
> device. Still I don't get sound on it.

You probably need to select the right device output. Try using aplay's -D
argument. In all cases, we don't support it yet in Fedora because it's a mess to
configure, and the software isn't ready. Feel free to contact the bluez-user
list on sourceforge to get more help getting it working.

<snip>
> gnome-vfs2-obexftp-0.4-6.fc9.i386

We don't use gnome-vfs2-obexftp anymore, nautilus will use gvfs instead.

Note You need to log in before you can comment on or make changes to this bug.