Bug 446497 - cumin logs int out of range
cumin logs int out of range
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
beta
All Linux
urgent Severity high
: ---
: ---
Assigned To: Justin Ross
Jeff Needle
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 16:46 EDT by Carl Trieloff
Modified: 2011-08-12 12:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 11:05:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Trieloff 2008-05-14 16:46:22 EDT
Description of problem:

Exception in thread Thread-13:
Traceback (most recent call last):
  File "/usr/lib64/python2.5/threading.py", line 460, in __bootstrap
    self.run()
  File "/usr/lib64/python2.5/threading.py", line 440, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/home/cctrieloff/apache/qpid1/python/qpid/queue.py", line 79, in run
    self.listener(o)
  File "/home/cctrieloff/apache/qpid1/python/qpid/management.py", line 138, in
topicCb
    self.tcb (self, msg)
  File "/home/cctrieloff/apache/qpid1/python/qpid/management.py", line 308, in
topicCb
    self.parse (ch, codec, hdr[0], hdr[1])
  File "/home/cctrieloff/apache/qpid1/python/qpid/management.py", line 730, in parse
    self.parseContent (ch, 'I', codec)
  File "/home/cctrieloff/apache/qpid1/python/qpid/management.py", line 721, in
parseContent
    self.instCb   (ch.context, classKey, row, timestamps)
  File "/home/cctrieloff/rhm/trunk/mgmt/mint/python/mint/__init__.py", line 418,
in instCallback
    objStats.syncUpdate()
  File "/usr/lib/python2.5/site-packages/sqlobject/main.py", line 1006, in
syncUpdate
    self._connection._SO_update(self, values)
  File "/usr/lib/python2.5/site-packages/sqlobject/dbconnection.py", line 647,
in _SO_update
    self.sqlrepr(so.id)))
  File "/usr/lib/python2.5/site-packages/sqlobject/dbconnection.py", line 342,
in query
    return self._runWithConnection(self._query, s)
  File "/usr/lib/python2.5/site-packages/sqlobject/dbconnection.py", line 255,
in _runWithConnection
    val = meth(conn, *args)
  File "/usr/lib/python2.5/site-packages/sqlobject/dbconnection.py", line 339,
in _query
    self._executeRetry(conn, conn.cursor(), s)
  File "/usr/lib/python2.5/site-packages/sqlobject/dbconnection.py", line 334,
in _executeRetry
    return cursor.execute(query)
ProgrammingError: integer out of range
Comment 1 Justin Ross 2008-05-28 16:10:29 EDT
Nuno and I haven't been able to reproduce this error.  Was there anything in
particular you were doing to produce it?
Comment 2 Carl Trieloff 2008-05-28 17:18:30 EDT
I was flipping through all the screens where we have graphs.

Carl.
Comment 3 Carl Trieloff 2008-05-30 17:22:12 EDT
I expect this was due to updates, can't reproduce anymore so will push MODI as I
reported it.
Comment 4 Mike Bonnet 2008-06-19 23:51:25 EDT
cumin-0.1.2155-1.el5, qpidc-0.2.667603-1.el5, qpidc-perftest-0.2.667603-1.el5, qpidd-0.2.667603-1.el5, and python-qpid-0.2.668378-1.el5 have been pushed to the staging repo for testing

Note You need to log in before you can comment on or make changes to this bug.