Bug 446498 - virt-manager never displays "finish" button if shared physical device selected during creation of FV guest
virt-manager never displays "finish" button if shared physical device selecte...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.2
i386 Linux
high Severity high
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
: 465413 (view as bug list)
Depends On:
Blocks: 449772
  Show dependency treegraph
 
Reported: 2008-05-14 16:46 EDT by Gary Case
Modified: 2009-12-14 16:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:20:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager logfile (69.73 KB, text/plain)
2008-06-12 16:58 EDT, Gary Case
no flags Details
Fix bridge default values (1.95 KB, application/octet-stream)
2008-09-17 10:18 EDT, Cole Robinson
no flags Details
Fix default bridge entry (3.63 KB, application/octet-stream)
2008-09-17 11:22 EDT, Cole Robinson
no flags Details

  None (edit)
Description Gary Case 2008-05-14 16:46:54 EDT
Description of problem:

Installation of fullvirt guest unable to complete if Shared physical device
chosen during install.

Version-Release number of selected component (if applicable):
virt-manager-0.5.3-8.el5

How reproducible:
Every time

Steps to Reproduce:
1. Run virt-manager
2. Click "New"
3. Name system
4. Choose FV guest
5. Point to install ISO of RHEL5, choose Linux OS and RHEL5 variant
6. Choose Simple file, accepting defaults
7. Change network to Shared physical device
8. Accept defaults on Memory and CPU
9. The "Finish" button never appears. It stays "Forward" and you're unable to
complete installation.
 
Actual results:

No guest installed.

Expected results:

Guest installed.

Additional info:
Clicking "Back" a few times and changing to Virtual Network makes the install
begin successfully.
Comment 1 RHEL Product and Program Management 2008-06-02 15:59:51 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Cole Robinson 2008-06-12 14:46:41 EDT
Hmm, bizarre. Is there any entry in the Shared physical device box when you
select it? Can you paste the contents of the 'Summary' screen after the mem/cpu
screen? Also, can you post ~/.virt-manager/virt-manager.log after duplicating
this? Thanks!
Comment 3 Gary Case 2008-06-12 16:22:47 EDT
Aha! You've found it. The entry in the shared physical device box says "eth1
(not bridged)" by default, which isn't a usable entry. It should either
automatically switch to 'peth0', which is usable, or it should refuse to let you
go forward past this page (Connect to host network) with an invalid entry
selected in the Shared Physical Device section.
Comment 4 Cole Robinson 2008-06-12 16:34:17 EDT
Okay so the failure comes when one of the 'Non Bridged' entires is selected I
take it? That makes more sense. I'll look into it. In the mean time the
~/.virt-manager/virt-manager.log will be helpful if you get the chance.
Comment 5 Gary Case 2008-06-12 16:58:03 EDT
Created attachment 309143 [details]
virt-manager logfile

I'm attaching the log file, complete with tracebacks:

[Thu, 12 Jun 2008 16:56:24 virt-manager 8097] ERROR (virt-manager:132)
Traceback
 (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 483, in
page_change
d
    self.window.get_widget("summary-net-target").set_text(net[1])
TypeError: GtkLabel.set_text() argument 1 must be string, not None
None
Comment 6 Cole Robinson 2008-06-12 17:22:05 EDT
Thanks for the help, I just committed a fix for this upstream:

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=7bc37ab455dd

So I'll see that it is pulled in for 5.3
Comment 8 Cole Robinson 2008-09-17 10:18:03 EDT
Created attachment 316963 [details]
Fix bridge default values

Patch also adds this functionality for the addhardware wizard (also upstream).
Comment 9 Cole Robinson 2008-09-17 10:20:45 EDT
Easiest way to test requires a machine with two nics. Previously, the default selection in the 'Physical Device' drop down would be ethX, the unbridged card. Now the default entry should be xenbr0, with the unbridged nic unselectable.
Comment 10 Cole Robinson 2008-09-17 11:22:14 EDT
Created attachment 316974 [details]
Fix default bridge entry

Whoops, first patch was the wrong one. This is the intended patch.
Comment 13 Cole Robinson 2008-10-03 10:07:58 EDT
*** Bug 465413 has been marked as a duplicate of this bug. ***
Comment 15 errata-xmlrpc 2009-01-20 16:20:23 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0137.html

Note You need to log in before you can comment on or make changes to this bug.