Bug 446528 - Volume OSD ugly with composite manager enabled
Volume OSD ugly with composite manager enabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: echo-icon-theme (Show other bugs)
10
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 18:56 EDT by Mathieu Bridon
Modified: 2014-06-18 05:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: echo-icon-theme-0.3.89.0-0.7.git1f550b3.fc10.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-05 08:00:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OSD without composite manager (195.92 KB, image/png)
2008-05-14 18:56 EDT, Mathieu Bridon
no flags Details
OSD with composite manager (219.42 KB, image/png)
2008-05-14 18:57 EDT, Mathieu Bridon
no flags Details

  None (edit)
Description Mathieu Bridon 2008-05-14 18:56:36 EDT
Description of problem:
The OSD showing the sound volume looks pixelized and ugly when using metacity
with composite manager enabled.

Version-Release number of selected component (if applicable):
metacity-2.22.0-3.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. use the multimedia key of your laptop to change the sound volume. You should
see the OSD like on attachment 
2 [details]. enable the composite manager with:
gconftool –type=bool -s /apps/metacity/general/compositing_manager 1
3. use the multimedia key of your laptop to change the sound volume. You should
see the OSD like on attachment
  
Actual results:
The OSD looks pixelised and rather ugly (which is annoying considered the fact
that you get it when adding some eye cnady to the desktop :)

Expected results:
The OSD should look the same, or better.

Additional info:
I selected metacity as the component because the problem appears when enabling
the composite manager in metacity. However, I couldn't find out which component
is responsible for displaying the OSD, so if metacity is not guilty, feel free
to modify my bug report in consequence.
Comment 1 Mathieu Bridon 2008-05-14 18:56:36 EDT
Created attachment 305413 [details]
OSD without composite manager
Comment 2 Mathieu Bridon 2008-05-14 18:57:24 EDT
Created attachment 305414 [details]
OSD with composite manager
Comment 3 Mathieu Bridon 2008-07-14 06:27:34 EDT
This is totally fixed with update from Rawhide:
echo-icon-theme-0.3.89.0-0.7.git1f550b3.fc10.noarch

So it was a echo issue, not a metacity one. I'm changing the component to
echo-icon-theme.

Release echo-icon-theme-0.3.2.1-1.fc9.noarch.rpm from updates-testing still
doesn't resolve this bug.

Hope it will be pushed from Rawhide to updates soon for everyone to enjoy it :)
Comment 4 Mathieu Bridon 2008-10-04 05:59:40 EDT
echo-icon-theme-0.3.3-1.fc9 (from updates repository) still doesn't resolve the issue.

However, it is fixed in Rawhide, and thus in fedora-icon-theme for F10.

F10 won't know this problem, could it be ported to F9 too ?
Comment 5 Mathieu Bridon 2009-01-02 06:33:47 EST
As I said, this is fixed in F10.

Didn't check in F9 though.

Is anyone reading this bug report ? :)
Comment 6 Matěj Cepl 2009-04-05 08:00:00 EDT
This is your lucky day! Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.