Bug 446535 - popping when initializing onboard sound, and many other times
popping when initializing onboard sound, and many other times
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 19:15 EDT by Tom Horsley
Modified: 2009-09-23 01:40 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 03:29:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2008-05-14 19:15:29 EDT
Description of problem:

The new fedora 9 install on this machine makes a couple of annoying
pops that sound like someone thumping a microphone when initializing
the sound system (I expect to hear someone say "Is this thing on?"
right after it :-). Several previous versions of fedora including
8 and 7 do not exhibit this symptom, so it must be possible to initialize
this this without the sound effects.

Version-Release number of selected component (if applicable):

I've done no updates since the install from the fedora 9 release DVD,
so whatever shipped is the version I have.

How reproducible:

every time I boot

Steps to Reproduce:
1. see above
  
Actual results:

pop! pop!

Expected results:

blessed silence

Additional info:

This is a nVidia Corp CK804 AC'97 Audio Controller built in to
the biostar motherboard I have (BIOSTAR TForce4U socket 939).
On fedora 8, it is using the snd-intel8x0 driver (don't know if
that is still the same on fedora 9 or not).
Comment 1 Tom Horsley 2008-06-10 21:27:07 EDT
New data: The recent 2.6.25 kernel update for fedora 8 has now infected
it as well, so both fedora 8 and 9 now produce these pops when initializing
the sound (it happens during the "Initializing udev:" part of the
boot sequence).
Comment 2 Gerry Tool 2008-10-22 13:33:02 EDT
This is also occuring in F10Beta.  My rawhide system is fully updated as of now, 10/22/2008, 12:00 pm.  I can confirm that the popping happens during the UDEV startup.  I get 10 messages "Don't know how to make device xxx". The message that has appeared just as it pops is xxx = lp3.  Prior to that, the devices listed are loop 1 - loop7, lp1, lp2.

My kernel is
uname -a
Linux f10beta.thetoolshed.us 2.6.27.3-30.rc1.fc10.i686 #1 SMP Mon Oct 20 01:35:32 EDT 2008 i686 athlon i386 GNU/Linux

My sound hardware is Nvidia CK804.  Sound functions using .ogg files, and some system sounds work.  I haven't tested other sound types.
Comment 3 Gerry Tool 2008-10-22 13:35:19 EDT
I forgot to mention that this popping does NOT occur on my f9 installation on the same machine, separate partition.
Comment 4 john5342 2008-10-22 15:42:31 EDT
I get this exact same problem with popping during "Initializing udev" again using an AC'97 CK804 chipset and kernel 2.6.26.5-45.fc9.x86_64. I also have the problem mentioned in bug 466840.

Should also mention that to the best of my knowledge the chipsets in both bugs (including the intel chip in the mentioned bug) use the snd_intel8x0 kernel module. Possibly related?
Comment 5 Stephen Warren 2008-12-03 00:37:08 EST
I am seeing this in Fedora 10 too, hence updating the bug version to avoid the bug being closed prematurely.

I now get a loud pop during boot, and also in skype any time I open options, and then play a test sound, also sometimes when the Pulse Audio volume control is started.

kernel 2.6.27.5-117.fc10.i686
Driver is apparently snd_intel8x0 (Dell Inspiron 9300)

Note: I did *not* see this under Fedora 9, with latest updates up to around 2008/12/01.
Comment 6 Jonathan Ryshpan 2009-01-02 01:35:36 EST
Booting F10, I hear two loud clicks about 500 msec apart just after the
"Starting udev" message appears.  For a while, there were similar clicks starting F9, but they disappeared after a kernel upgrade (Sorry, I don't remember which one.)

The "sound card" is built into the motherboard.  Alsa identifies it:
 $ cat /proc/asound/cards
 0 [CK8S           ]: NFORCE - NVidia CK8S
                      NVidia CK8S with ALC850 at irq 20
 1 [UART           ]: MPU-401 UART - MPU-401 UART
                      MPU-401 UART at 0x300, irq 5

The system is:
$ uname -a
Linux localhost.localdomain 2.6.27.9-159.fc10.x86_64 #1 SMP Tue Dec 16 14:47:52 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

with all current updates installed.
Comment 7 moorray 2009-01-05 16:52:06 EST
Exactly the same problem, my platform:

$ cat /proc/asound/cards
 0 [CK804          ]: NFORCE - NVidia CK804
                      NVidia CK804 with ALC850 at irq 23

$ uname -a
Linux north 2.6.27.9-159.fc10.i686 #1 SMP Tue Dec 16 15:12:04 EST 2008 i686 athlon i386 GNU/Linux
Comment 8 Leonard 2009-01-30 12:38:47 EST
I get very loud popping at startup and throughout any sounds played. I have a base Pentium4 system, does NOT have 64-bit, and has an integrated AC '97 chipset with NVIDIA GeForce FX 5300.  I never had ANY sound problems with previous Fedora installations. 



I have tried using Amarok and XMMS. 

The only time I can cure the problem is to disable Pulse Audio, but then can't get XMMS to work.
Comment 9 Jaroslav Kysela 2009-02-04 07:21:40 EST
Does speaker-test utility work when you disable Pulse Audio?
Comment 10 Leonard 2009-02-05 15:54:55 EST
(In reply to comment #9)
> Does speaker-test utility work when you disable Pulse Audio?

Correction: XMMS works, Amarok does not, when Pulse Audio is disabled.

Speaker test does work with PA disabled.
Comment 11 Jaroslav Kysela 2009-02-06 05:24:53 EST
Thanks. To all others - are pops affected in any way on your systems when you disable Pulse Audio?
Comment 12 john5342 2009-02-06 14:53:18 EST
Popping has dissapeared for me recently. Forget exactly when. Works without popping both with and without PulseAudio. Current packages i am using are:

kernel-2.6.27.12-170.2.5.fc10
alsa-lib-1.0.19-1.fc10

Still have major issues with surround sound but thats the subject for another bug.
Comment 13 Tom Horsley 2009-02-06 15:57:03 EST
This bugzilla seems to have diverged from my original report. My report
was strictly about boot time popping during udev (before any pulseaudio
nonsense is doing anything).

The boot time popping still happens for me.

Other audio problems after the system is up as described in here never
happened to me at all (perhaps because I did a "yum erase pulseaudio").

Don't anyone go closing this bug because some completely different
problem went away for someone else :-).
Comment 14 john5342 2009-02-06 16:23:19 EST
(In reply to comment #13)
> This bugzilla seems to have diverged from my original report. My report
> was strictly about boot time popping during udev (before any pulseaudio
> nonsense is doing anything).
> 
> The boot time popping still happens for me.
> 
> Other audio problems after the system is up as described in here never
> happened to me at all (perhaps because I did a "yum erase pulseaudio").
> 
> Don't anyone go closing this bug because some completely different
> problem went away for someone else :-).

My comment of no popping also applies to starting udev which up untill relatively recently also happened to me so its not a completely different bug (it at least has the same symptoms). I also had popping and crackles at other times which were also solved. I am sorry if that sounded like i was diverging from the original topic. Ofcourse i never suggested that the issue was resolved for everyone. Good luck finding a solution :)
Comment 15 Tom Horsley 2009-02-06 19:22:42 EST
Actually, I take it back :-). Some very recent update does seem to have
fixed the popping at boot time for me. I just rebooted a couple of times
specifically to test it, making sure that the volume was turned up on
the speakers, and there was no pop at boot and sound worked fine
after the system was up.

It must have been some very recent update, because I'm sure I've heard
the boot time pop in the recent past.
Comment 16 Stephen Warren 2009-02-09 12:04:25 EST
I still have the popping sound on both laptops I have access to. Which kernel/... package version is supposed to have fixed this???

Note: If I remember correctly from my reboots yesterday, the repro rate on this issue isn't 100%, but more like 75%. Could the poster in comemnt #15 have been mistaken it was fixed for him too?
Comment 17 Alex Eggeman 2009-09-11 04:49:51 EDT
This seems to have started again after the recent upgrade from 2.6.29-6 to 2.6.30-5 on my Dell latitude.

Was there a fix published or was it taken care of in the dist upgrade?
Comment 18 Jordan_ad 2009-09-23 01:40:30 EDT
I am using a HP DV6000T CTO with the latest updates of Pulsaudio and during bootup and loggin I get the [above] described popping noise, as though there was a reset for a sudden jolt to the speakers.  Obviously the bug seems to be directly linked to the fact that all of the above mentioned systems are laptops, or use laptop sound cards.  PLEASE TAKE NOTE OF THIS BUG!  This seems very widespread and linked to the recent pulsaudio (and maybe ALSA) package updates.

Note You need to log in before you can comment on or make changes to this bug.