Bug 446546 - Nvidia patch and ALLOW_NV_SUSPEND override got silently dropped
Nvidia patch and ALLOW_NV_SUSPEND override got silently dropped
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 20:47 EDT by Paul Bolle
Modified: 2015-03-04 20:19 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.99.4-19.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 22:20:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Bolle 2008-05-14 20:47:38 EDT
Description of problem:
One of the F8 common issues was "Suspend/Resume Problem With Nvidia cards"
(http://fedoraproject.org/wiki/Bugs/F8Common?action=show&redirect=Bugs%2FCommon#head-937d298d3830e8157582a37bbf882ca385eb8fed).
The patch for this issue (and the ALLOW_NV_SUSPEND override) got silently dropped.

Version-Release number of selected component (if applicable):
pm-utils-1.1.0-7.fc9.i386

How reproducible:
n/a

Steps to Reproduce:
1. n/a
2.
3.
  
Actual results:
n/a

Expected results:
n/a

Additional info:
This is the commit that dropped the patch for this issue (and the override) in
the F8 tree (even removing it from the rpm changelog!):
http://cvs.fedoraproject.org/viewcvs/rpms/pm-utils/F-8/pm-utils.spec?r1=1.83&r2=1.84
 As far as I can see, this patch and the override have never been added to the
F9 tree. 

Shouldn't the removal of the patch and the override be somehow documented or
publicized, especially since the issue and the override were publicized?

Secondly, wouldn't it be polite to make some noise (e.g. in /var/log/messages)
if the deprecated ALLOW_NV_SUSPEND override is detected?

(Of course, this all assumes the patch concerning this issue was deliberately
dropped, but that isn't really clear.)
Comment 1 Richard Hughes 2008-05-15 03:53:48 EDT
Option like this need to be directed upstream; there is little point Fedora
alone carrying a distro option like this. Can you please email the pm-utils
mailing list and explain the problem. When it's upstream, I will release a
snapshot for F9. Thanks.
Comment 2 Till Maas 2008-05-15 04:52:21 EDT
(In reply to comment #1)
> Option like this need to be directed upstream; there is little point Fedora
> alone carrying a distro option like this. Can you please email the pm-utils
> mailing list and explain the problem. When it's upstream, I will release a
> snapshot for F9. Thanks.

Actually I plan to add the patch back to the spec, because I did not remove it
intentionally and the package is still in testing. Afaik, the patch was never
intended to be added to any other release than F8, therefore it does not need to
be added to upstream, e.g. the patch was not applied to devel iirc, which is why
I removed it by accident.
Comment 3 Fedora Update System 2008-05-18 13:24:06 EDT
pm-utils-0.99.4-18.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-06-09 18:28:06 EDT
pm-utils-0.99.4-19.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-06-11 00:34:39 EDT
pm-utils-0.99.4-19.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pm-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5187
Comment 6 Fedora Update System 2008-06-12 22:20:01 EDT
pm-utils-0.99.4-19.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.