Bug 446580 - Cant send files to my Fedora PC via bluetooth
Cant send files to my Fedora PC via bluetooth
Status: CLOSED DUPLICATE of bug 444228
Product: Fedora
Classification: Fedora
Component: bluez-gnome (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 03:15 EDT by Patrick Steiner
Modified: 2008-06-02 04:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 04:41:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Steiner 2008-05-15 03:15:15 EDT
i can send any files via bluetooth to my fedora 9 machine.

since fedora 9 there isn't any gnome-obex-server any more, so i enabled
bluetooth file sharing via personal file sharing.

ps -A shows that there is a obex-data-server process running, but if i try to
send a file to my machine i always get an error on my phone. i already tried a
different one.

Browsing my phone works and i also can send files to my phone.

i also have paired my phone with the fedora 9 station.
Comment 1 Jeffrey D. Yuille 2008-05-15 16:55:26 EDT
I am having the same problem.  I can sync my Palm Treo 680 via bluetooth but I
cannot send individual files (mp3 music, address book files) through bluetooth
to my Fedora 9 desktop and laptop. 
Comment 2 Ondrej Vasik 2008-05-19 09:14:24 EDT
Reassigning to bluez-gnome as more probable component.
Comment 3 Bastien Nocera 2008-05-19 09:36:06 EDT
Please attach, from the machine with the problems, the output of:
rpm -qa "*bluez*" "*obex*"
sdptool browse local
and
gconftool-2 --recursive-list /desktop/gnome/file_sharing
Comment 4 Patrick Steiner 2008-05-19 09:59:27 EDT
rpm output:

bluez-utils-cups-3.30-2.fc9.i386
openobex-1.3-11.fc9.i386
bluez-utils-alsa-3.30-2.fc9.i386
bluez-gnome-0.25-1.fc9.i386
obex-data-server-0.3.1-1.fc9.i386
bluez-libs-3.30-1.fc9.i386
bluez-utils-3.30-2.fc9.i386
gnome-vfs2-obexftp-0.4-6.fc9.i386
bluez-libs-devel-3.30-1.fc9.i386


sdptool output:

Browsing FF:FF:FF:00:00:00 ...
Service Name: Headset Audio Gateway
Service RecHandle: 0x10000
Service Class ID List:
  "Headset Audio Gateway" (0x1112)
  "Generic Audio" (0x1203)
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 12
Profile Descriptor List:
  "Headset" (0x1108)
    Version: 0x0100

Service Name: Audio Source
Service RecHandle: 0x10001
Service Class ID List:
  "Audio Source" (0x110a)
Protocol Descriptor List:
  "L2CAP" (0x0100)
    PSM: 25
  "AVDTP" (0x0019)
    uint16: 0x100
Profile Descriptor List:
  "Advanced Audio" (0x110d)
    Version: 0x0100

Service Name: AVRCP TG
Service RecHandle: 0x10002
Service Class ID List:
  "AV Remote Target" (0x110c)
Protocol Descriptor List:
  "L2CAP" (0x0100)
    PSM: 23
  "AVCTP" (0x0017)
    uint16: 0x103
Profile Descriptor List:
  "AV Remote" (0x110e)
    Version: 0x0103

Service Name: AVRCP CT
Service RecHandle: 0x10003
Service Class ID List:
  "AV Remote" (0x110e)
Protocol Descriptor List:
  "L2CAP" (0x0100)
    PSM: 23
  "AVCTP" (0x0017)
    uint16: 0x103
Profile Descriptor List:
  "AV Remote" (0x110e)
    Version: 0x0103



gconf output:

 bluetooth_obexpush_enabled = true
 require_password = never
 bluetooth_accept_files = always
 bluetooth_enabled = true
 bluetooth_notify = false
 bluetooth_allow_write = true
 enabled = false
 bluetooth_require_pairing = true


hope this helps...
Comment 5 Patrick Steiner 2008-05-26 06:01:19 EDT
here are the files from a second machine with the same problems:

bluez-utils-cups-3.30-2.fc9.i386
openobex-1.3-11.fc9.i386
bluez-utils-alsa-3.30-2.fc9.i386
bluez-gnome-0.25-1.fc9.i386
obex-data-server-0.3.1-1.fc9.i386
bluez-libs-3.30-1.fc9.i386
bluez-utils-3.30-2.fc9.i386
gnome-vfs2-obexftp-0.4-6.fc9.i386
bluez-libs-devel-3.30-1.fc9.i386

$ sdptool browse local
Browsing FF:FF:FF:00:00:00 ...
Service Name: Headset Audio Gateway
Service RecHandle: 0x10000
Service Class ID List:
  "Headset Audio Gateway" (0x1112)
  "Generic Audio" (0x1203)
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 12
Profile Descriptor List:
  "Headset" (0x1108)
    Version: 0x0100

Service Name: Audio Source
Service RecHandle: 0x10001
Service Class ID List:
  "Audio Source" (0x110a)
Protocol Descriptor List:
  "L2CAP" (0x0100)
    PSM: 25
  "AVDTP" (0x0019)
    uint16: 0x100
Profile Descriptor List:
  "Advanced Audio" (0x110d)
    Version: 0x0100

Service Name: AVRCP TG
Service RecHandle: 0x10002
Service Class ID List:
  "AV Remote Target" (0x110c)
Protocol Descriptor List:
  "L2CAP" (0x0100)
    PSM: 23
  "AVCTP" (0x0017)
    uint16: 0x103
Profile Descriptor List:
  "AV Remote" (0x110e)
    Version: 0x0103

Service Name: AVRCP CT
Service RecHandle: 0x10003
Service Class ID List:
  "AV Remote" (0x110e)
Protocol Descriptor List:
  "L2CAP" (0x0100)
    PSM: 23
  "AVCTP" (0x0017)
    uint16: 0x103
Profile Descriptor List:
  "AV Remote" (0x110e)
    Version: 0x0103

Service Name: OBEX File Transfer
Service RecHandle: 0x10004
Service Class ID List:
  "OBEX File Transfer" (0x1106)
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 10
  "OBEX" (0x0008)
Profile Descriptor List:
  "OBEX File Transfer" (0x1106)
    Version: 0x0100

Service Name: OBEX Object Push
Service RecHandle: 0x10005
Service Class ID List:
  "OBEX Object Push" (0x1105)
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 9
  "OBEX" (0x0008)
Profile Descriptor List:
  "OBEX Object Push" (0x1105)
    Version: 0x0100

$ gconftool-2 --recursive-list /desktop/gnome/file_sharing
 bluetooth_obexpush_enabled = true
 require_password = never
 bluetooth_accept_files = always
 bluetooth_enabled = true
 bluetooth_notify = false
 bluetooth_allow_write = true
 enabled = false
 bluetooth_require_pairing = true

Comment 6 Bastien Nocera 2008-05-30 11:29:37 EDT
And what's the output of hciconfig on those machines?

The first machine had its bluetooth service restarted, and obex-data-server
doesn't re-advertise the services[1]. You should disable Bluetooth sharing, and
re-enable it after a couple of seconds, and the "OBEX Object Push" and "OBEX
File Transfer" services should show again in the "sdptool browse local" output.

[1]: see http://bugzilla.gnome.org/show_bug.cgi?id=309232
Comment 7 Patrick Steiner 2008-06-02 03:58:20 EDT
hciconfig -a
hci0:	Type: USB
	BD Address: 00:15:83:BA:EF:1C ACL MTU: 384:8 SCO MTU: 64:8
	UP RUNNING PSCAN ISCAN 
	RX bytes:1286 acl:0 sco:0 events:37 errors:0
	TX bytes:651 acl:0 sco:0 commands:37 errors:0
	Features: 0xff 0xff 0x8f 0xfe 0x9b 0xf9 0x00 0x80
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Link policy: RSWITCH HOLD SNIFF PARK 
	Link mode: SLAVE ACCEPT 
	Name: 'XXX'
	Class: 0x180104
	Service Classes: Capturing, Object Transfer
	Device Class: Computer, Desktop workstation
	HCI Ver: 2.0 (0x3) HCI Rev: 0x7a6 LMP Ver: 2.0 (0x3) LMP Subver: 0x7a6
	Manufacturer: Cambridge Silicon Radio (10)
Comment 8 Patrick Steiner 2008-06-02 04:03:18 EDT
ok, i figured out, that it works, if i send a file from a windows vista notebook.

sending from my symbian phones (sony ericsson m600i or nokia 6021) doesnt work.

so it looks like a obex-data-server bug?
Comment 9 Bastien Nocera 2008-06-02 04:41:35 EDT
I should have asked about the type of phone.

*** This bug has been marked as a duplicate of 444228 ***

Note You need to log in before you can comment on or make changes to this bug.