Bug 446589 - Yum complains about non-ascii characters
Yum complains about non-ascii characters
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 444603 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 05:02 EDT by Alexey Torkhov
Modified: 2008-06-03 06:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 06:59:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Torkhov 2008-05-15 05:02:46 EDT
Description of problem:
I've updated Fedora 8 to 9.
Running "debuginfo-install epiphany.i386" cause error:

Traceback (most recent call last):
  File "/usr/bin/debuginfo-install", line 124, in <module>
    util = DebugInfoInstall()
  File "/usr/bin/debuginfo-install", line 42, in __init__
    self.main()
  File "/usr/bin/debuginfo-install", line 82, in main
    self.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 348, in doTransaction
    if not self.userconfirm():
  File "/usr/share/yum-cli/output.py", line 352, in userconfirm
    choice = raw_input(_('Is this ok [y/N]: '))
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-8:
ordinal not in range(128)


Version-Release number of selected component (if applicable):
yum-utils-1.1.13-2.fc9.noarch

How reproducible:
Always.
Comment 1 Bill Nottingham 2008-05-15 13:41:33 EDT
What language are you running in?
Comment 2 Alexey Torkhov 2008-05-15 14:01:08 EDT
Russian. Locale is ru_RU.UTF-8.
Comment 3 Tim Lauridsen 2008-05-30 08:09:55 EDT
I can reproduce the error, it is very wierd.

LANG="ru_RU.UTF-8" debug-install thunderbird 
fails

LANG="ru_RU.UTF-8" yum remove thunderbird, can show the russian message for "Is
this ok [y/N]: " without failing"
Comment 4 Tim Lauridsen 2008-05-30 08:30:36 EDT
*** Bug 444603 has been marked as a duplicate of this bug. ***
Comment 5 Tim Lauridsen 2008-06-03 06:59:09 EDT
Works now, with the current upstream yum-3_2_X branch, so it will be fixed in
next yum release.

Note You need to log in before you can comment on or make changes to this bug.