Bug 446593 - FEAT: HwCert catalog should reject results from testing versions of HTS
FEAT: HwCert catalog should reject results from testing versions of HTS
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
5
All Linux
low Severity low
: ---
: ---
Assigned To: XINSUN
Yu Shao
:
: 456053 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 05:18 EDT by YangKun
Modified: 2008-10-28 02:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 02:16:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch Improve: (14.16 KB, patch)
2008-09-03 14:02 EDT, XINSUN
no flags Details | Diff
New template to display the valid hts version and provide the hts_nvr_override option. (706 bytes, patch)
2008-09-03 14:05 EDT, XINSUN
no flags Details | Diff
Patch Improve: (17.43 KB, patch)
2008-09-04 23:37 EDT, XINSUN
no flags Details | Diff
The sanitycheck_hts_version.pl (2.73 KB, patch)
2008-09-05 02:01 EDT, XINSUN
no flags Details | Diff
sanitycheck_hts_version.cron (125 bytes, patch)
2008-09-05 02:01 EDT, XINSUN
no flags Details | Diff
Patch Improve: (18.11 KB, application/octet-stream)
2008-09-09 06:10 EDT, XINSUN
no flags Details
Improve: sanitycheck_hts_version.pl (3.76 KB, patch)
2008-09-09 06:11 EDT, XINSUN
no flags Details | Diff

  None (edit)
Description YangKun 2008-05-15 05:18:12 EDT
only the GA version and the subsequent updates of HTS can be used for
certification. But some vendors did use testing version of HTS and uploaded the
results. We should not let that happen again.
Comment 3 Rob Landry 2008-08-07 10:12:07 EDT
The catalog can/should figure out the hts version from the results (depending this may require a change in hts) however ideally we don't want to add an entered by hand maintenance burden, this should be automated using a similar mechanism as the valid RHEL version check, eg. calls into the RH systems which know the answers.

The life cycle is already in the policy and unless we want to have spin the policy guide every time we spin hts we should not put version numbers in the policy guide, that said there is value in providing the current version numbers that are accepted and when they will expire within the catalog, I would suggest we could add a logged in header which provides "Current hts: {version} Previous hts:  (accecpted until {date}".
Comment 8 XINSUN 2008-09-03 14:02:32 EDT
Created attachment 315671 [details]
Patch Improve:
Comment 9 XINSUN 2008-09-03 14:05:14 EDT
Created attachment 315672 [details]
New template to display the valid hts version and provide the hts_nvr_override option.
Comment 13 XINSUN 2008-09-04 23:37:19 EDT
Created attachment 315825 [details]
Patch Improve:
Comment 16 XINSUN 2008-09-05 02:01:00 EDT
Created attachment 315833 [details]
The sanitycheck_hts_version.pl
Comment 17 XINSUN 2008-09-05 02:01:47 EDT
Created attachment 315834 [details]
sanitycheck_hts_version.cron
Comment 19 Rob Landry 2008-09-05 12:25:51 EDT
[ attachment.cgi ]

check.

[ defparams.pl && data/params (?)]


+   desc => 'Send mail to notify a specific hts version has expired after hts version sanitycheck',

+Subject: NOTICE: HTS version %expiredhtsnvr% has been deprecated.
+
+[This e-mail has been automatically generated.]
+
+HTS version %expiredhtsnvr% has expired starting today.  Test result packages which were generated using this version of HTS are no longer accepted and will be rejected by the Hardware Catalog.


[ upload_packages.html.tmpl ]

         <em>Enter the path to the results package or spec file on your computer.</em><p/>  <-- instead of <br/>

[ create.html.tmpl ]

  ...We should make this mimic the upload_packages page, "File" instead of "Certification Package File" and the <br/> and dropping the " This file can be found ..."

[ sanitycheck_hts_version.pl ]

What's the purpose of this conditional?  It should work without it from my read?
    if ($next_release_date) {
       ...
    }
    $next_release_date = $release_date;

...the while loop should pickup on there not being another entry, which means it's only when an NVR fails to have a release date specified which we can avoid by simply defining the release_date as not null during table creation?
Comment 24 XINSUN 2008-09-09 06:10:35 EDT
Created attachment 316167 [details]
Patch Improve:
Comment 25 XINSUN 2008-09-09 06:11:30 EDT
Created attachment 316168 [details]
Improve: sanitycheck_hts_version.pl
Comment 26 Greg Nichols 2008-09-12 14:34:22 EDT
*** Bug 456053 has been marked as a duplicate of this bug. ***
Comment 27 Rob Landry 2008-09-18 15:47:18 EDT
defparams.pl

+HTS version %expiringhtsnvr% will expire at %expiredate%. Test result packages which were generated using this version of HTS are no longer accepted and will
+be rejected by the Hardware Catalog after %expiredate%.

should be

Starting on %expiredate%, test result package generated using %expiringhtsnvr% will no longer be accepted and will be rejected by the Hardware Catalog.  Test result packages generated using this version of HTS will need to be submitted before this date.

data/params

These changes will get overwritten by cfengine on the live server, as well IIRC this is generated by defparams.pl(?) so we don't need them in the patchset?

upload_packages.html.tmpl

@@ -66,10 +78,12 @@
Any reason for the hwcert-edit value to be true for nvr override?

template/en/default/bug/create/create.html.tmpl

@@ -179,7 +190,16 @@
Any reason for the hwcert-edit value to be true for nvr override?
Comment 28 Rob Landry 2008-10-03 00:19:05 EDT
checked into cvs, applied the above, changed the default to false.

Note You need to log in before you can comment on or make changes to this bug.