Bug 44660 - sound problems in startup (really all platforms)
Summary: sound problems in startup (really all platforms)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.3
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-15 02:09 UTC by Michal Jaegermann
Modified: 2014-03-17 02:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 19:49:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2001-06-15 02:09:25 UTC
rc.sysconfig make loading sound modules conditional with the following
test:

# Load sound modules iff they need persistent DMA buffers
if grep -q "options sound dmabuf=1" /etc/modules.conf 2>/dev/null ; then
....

This is too rough.  This action will happen even if that line will be
commented out but changes in a white space, without affecting a modprobe
semantics, will kill that.  This should be

if modprobe -c | grep -q "options sound dmabuf=1" ; then
....

to resolve all these issues at once.

OTOH, because sound modules not always will be loaded in startup files,
then something like that seems to be needed in /etc/modules.conf or mixer
settings with autoloaded modules will be not kept.

if -f /etc/.aumixrc
	if -f /bin/aumix-minimal
		post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
	endif
endif
if -f /bin/aumix-minimal
         pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
endif

On the top of it /etc/.aumixrc is a poor choice.  '/' can be mounted
read-only so this should be somewhere in /var/.

  Michal
  michal@harddata.com

Comment 1 Bill Nottingham 2001-06-18 02:08:53 UTC
The post-install, etc. commands are already added any time sound is configured.

Comment 2 Glen Foster 2001-07-13 22:15:47 UTC
This defect considered SHOULD-FIX for Fairfax gold-release.

Comment 3 Bill Nottingham 2005-04-05 19:49:16 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

OSS is dead, so this code isn't included any more.


Note You need to log in before you can comment on or make changes to this bug.