Bug 446607 - gdal segfault sometimes
gdal segfault sometimes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdal (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Balint Cristian
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 06:48 EDT by Balint Cristian
Modified: 2009-03-18 17:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.5.1-6.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-17 18:26:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Balint Cristian 2008-05-15 06:48:08 EDT
Description of problem:
gdal segfault sometimes

Version-Release number of selected component (if applicable):
gdal-1.5.1-5.fc9
Comment 1 Balint Cristian 2008-05-15 06:48:37 EDT
solved disabling stack protector at compile time.
Comment 2 Fedora Update System 2008-05-15 06:49:19 EDT
gdal-1.5.1-6.fc9 has been submitted as an update for Fedora 9
Comment 3 Fedora Update System 2008-05-17 18:26:38 EDT
gdal-1.5.1-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Even Rouault 2009-03-18 17:38:12 EDT
I'd like to post here the following message I've posted on gdal-dev yesterday :


cited from:

http://lists.osgeo.org/pipermail/gdal-dev/2009-March/020022.html
[gdal-dev] [SOLVED] GDAL crashing on Ubuntu 8.10

------- begin citation -----------------
Even Rouault even.rouault at mines-paris.org
Tue Mar 17 19:33:57 EDT 2009

Hi all,

Several users have reported over the past few weeks various crashes when
running GDAL, in particular in OGRFeature::GetFieldAsString(). It has been
finally identified that it was due to stricter guard logic in GCC that was
enabled in Ubuntu 8.10 and later versions because -D_FORTIFY_SOURCE=2 is set
by default and is activated when -O is set to 2 or higher.
A similar issue was detected in DTEDDataset::CreateCopy() a few weeks ago and
was also fixed.

The fixes have been applied to current development version, 1.6 stable branch
and 1.5 branch. Please refer to http://trac.osgeo.org/gdal/ticket/2896 and
http://trac.osgeo.org/gdal/ticket/2824 if you need to apply the relevant
patches without waiting for next stable releases.

However, it might be possible that similar issues still remain, especially in
less popular drivers, so please report it.

Best regards,

Even
------- end citation -----------------

I'm also a bit disappointed to see that such bugs are not reported to GDAL trac and gdal-dev mailing list. It appears that Ubuntu 8.10 has also had this problem and they did not properly report either... We, upstream, are not always good at fixing bugs, but it is hard to fix unreported bugs...

Note You need to log in before you can comment on or make changes to this bug.