Bug 446642 - gdm not working for non-local users
gdm not working for non-local users
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 10:27 EDT by Javier Palacios
Modified: 2015-01-14 18:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-15 10:39:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tail of /var/log/messages (14.57 KB, text/plain)
2008-05-15 10:27 EDT, Javier Palacios
no flags Details

  None (edit)
Description Javier Palacios 2008-05-15 10:27:54 EDT
I have networked users, with nss-ldap for name resolution and kerberos for
authentication, but only local users are allowed to perform a graphical login,
even after they have performed a console login.

I have selinux enabled, in permissive mode
Comment 1 Javier Palacios 2008-05-15 10:27:54 EDT
Created attachment 305491 [details]
tail of /var/log/messages
Comment 2 Ray Strode [halfline] 2008-05-15 10:34:51 EDT
So an interesting part of the output is:

May 15 16:18:05 cool gdm-session-worker[12831]: GSSAPI Error: Unspecified GSS
failure.  Minor code may provide more information (No credentials cache found)
May 15 16:18:05 cool gdm-session-worker[12831]: nss_ldap: failed to bind to LDAP
server ldap://carpanta.home.local/: Local error
May 15 16:18:05 cool gdm-session-worker[12831]: nss_ldap: could not search LDAP
server - Server is unavailable

Nalin, any idea what could cause those types of messages?
Comment 3 Javier Palacios 2008-05-15 10:39:40 EDT
Please apologize, as the problem does not really exists.

Due to unknown reasons, the nscd process was dead, so gdm was trying to read a
credentials file with permissions only for nscd user.

Note You need to log in before you can comment on or make changes to this bug.