Bug 446687 - Evolution forgets passwords when the PGP passphrase dialog opens
Evolution forgets passwords when the PGP passphrase dialog opens
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 13:18 EDT by Matt McCutchen
Modified: 2008-05-15 23:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-15 23:46:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 531439 None None None Never

  None (edit)
Description Matt McCutchen 2008-05-15 13:18:53 EDT
Description of problem:
Often when I send an email using Evolution, it deletes all of its remembered
passwords (both incoming and outgoing) from the GNOME keyring where they are
stored.  I have to reenter the passwords the next time they are needed, which is
a pain.

Version-Release number of selected component (if applicable):
evolution-2.22.1-2.fc9.i386
evolution-data-server-2.22.1-2.fc9.i386
gnome-keyring-2.22.1-1.fc9.i386

How reproducible:
Most of the time

Steps to Reproduce:

1. Press "Send / Receive" in Evolution and have it remember the password for an
incoming email account (if the password is not already remembered).
2. Open gnome-keyring-manager and note that the password is in the keyring.
3. Send an email in Evolution.
4. Open gnome-keyring-manager again.
5. Press "Send / Receive" again.

Actual results:
All Evolution passwords (except possibly the one for the mail sent in step 3)
disappear from the keyring, and Evolution prompts for them again in step 5.

Expected results:
The passwords remain in the keyring so Evolution does not need to prompt for them.
Comment 1 Matthew Barnes 2008-05-15 15:39:37 EDT
Do you use a password for your SMTP server?  Is it the same as your IMAP/POP
server?  If you run Evolution from a terminal window, do you see any warnings?
Comment 2 Matt McCutchen 2008-05-15 15:54:07 EDT
Yes, my SMTP server uses a password.  The servers are different: my POP servers
are pop.gmail.com and incoming.verizon.net and the SMTP server I was using is
mail.mattmccutchen.net .

I closed Evolution, ran "evolution --force-shutdown" followed by "evolution"
from the terminal (to try to get any children in the terminal too), and followed
the procedure, resulting in these warnings:

CalDAV Eplugin starting up ...
** (evolution:23102): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:23102): DEBUG: mailto URL program: evolution

(evolution:23102): e-data-server-ui-WARNING **: Unable to find password(s) in
keyring (Keyring reports: No matching results)

(evolution:23102): e-data-server-ui-WARNING **: Unable to find password(s) in
keyring (Keyring reports: No matching results)

(evolution:23102): e-data-server-ui-WARNING **: Unable to find password(s) in
keyring (Keyring reports: No matching results)

(evolution:23102): e-data-server-ui-WARNING **: Unable to find password(s) in
keyring (Keyring reports: No matching results)

(evolution:23102): e-data-server-ui-WARNING **: Unable to find password(s) in
keyring (Keyring reports: No matching results)

(evolution:23102): e-data-server-ui-WARNING **: Unable to find password(s) in
keyring (Keyring reports: No matching results)
BBDB spinning up...

BTW: gnome-keyring-manager shows two keyrings named "login" (bold) and
"session", and the email passwords are stored in "login".  In case there was
something wrong with the keyrings, I logged out of GNOME, deleted
~/.gnome2/keyrings, and logged back in, and the problem persisted.
Comment 3 Matthew Barnes 2008-05-15 17:11:19 EDT
Hmm, I thought this might be [1], for which I recently wrote a patch.  But you
say you're using different servers for POP and STMP, so now I'm not so sure.

So do the password prompts alternate between asking for your POP password and
your SMTP password?

Also, just as a sanity check, what do the Server and Username fields say for
those keys in the Keyring Manager app?  (You might have to check this after each
password prompt.)

[1] http://bugzilla.gnome.org/show_bug.cgi?id=354923
Comment 4 Matt McCutchen 2008-05-15 23:03:25 EDT
The plot thickens!  The SMTP account I am using is configured to PGP-sign
outgoing mail by default.  I click Send and the passphrase dialog appears.  With
the dialog still open (before I enter a passphrase or click OK or Cancel), if I
then start gnome-keyring-manager, all Evolution passwords are gone.

If I uncheck "Security" -> "PGP Sign" or use an account that does not sign
outgoing mail by default, I can send mail without losing any passwords.  If I
send one signed message (losing the passwords) but check "Remember this
passphrase for the remainder of this session" in the dialog, then I can send
subsequent signed messages without the dialog appearing and without losing any
passwords.  This leads me to believe that the problem is associated with the
passphrase dialog itself.  Also, sending encrypted but unsigned mail does not
lose any passwords.

I guess I just won't sign my mail until this is fixed.
Comment 5 Matthew Barnes 2008-05-15 23:46:05 EDT
Looks like this issue was reported upstream at:
http://bugzilla.gnome.org/show_bug.cgi?id=531439

Add yourself to the CC list for that bug.  I'll post further updates there.

Note You need to log in before you can comment on or make changes to this bug.