Bug 446721 - Xorg crashes at logout
Xorg crashes at logout
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 15:08 EDT by Terry Riley
Modified: 2008-09-18 15:27 EDT (History)
3 users (show)

See Also:
Fixed In Version: kernel 2.6.26-3.29
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 15:27:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (without xorg.conf) (26.04 KB, text/plain)
2008-05-28 15:19 EDT, Terry Riley
no flags Details
Xorg log (with xorg.conf) (14.28 KB, text/plain)
2008-05-28 15:20 EDT, Terry Riley
no flags Details
normal xorg.conf file (593 bytes, text/plain)
2008-05-28 15:20 EDT, Terry Riley
no flags Details
xorg.conf after running system-config-display (613 bytes, text/plain)
2008-05-28 15:21 EDT, Terry Riley
no flags Details
/var/log/gdm/:0.log (1.29 KB, text/plain)
2008-05-28 15:22 EDT, Terry Riley
no flags Details
Xorg.log collected after the crash ... (20.59 KB, application/octet-stream)
2008-08-13 04:11 EDT, Petr Tuma
no flags Details

  None (edit)
Description Terry Riley 2008-05-15 15:08:07 EDT
Description of problem:
Black screen and no VT's at logout; runs at 99% CPU otherwise.
Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.i386

How Reproducible: always


Steps to Reproduce:
1.login
2.logout
3.
  
Actual results:
Xorg runs at 99% of CPU; it produces a black screen (with a few small random
letters/images) after logout. VT's and keyboard not available after logout.

Expected results:
Xorg runs at small % CPU; logout produces new login screen

Additional info:Dell Optiplex 755, Intel 82Q35 Express Graphics Controller
Comment 1 Matěj Cepl 2008-05-28 12:55:05 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Terry Riley 2008-05-28 15:19:34 EDT
Created attachment 306973 [details]
Xorg log file (without xorg.conf)
Comment 3 Terry Riley 2008-05-28 15:20:09 EDT
Created attachment 306974 [details]
Xorg log (with xorg.conf)
Comment 4 Terry Riley 2008-05-28 15:20:39 EDT
Created attachment 306975 [details]
normal xorg.conf file
Comment 5 Terry Riley 2008-05-28 15:21:13 EDT
Created attachment 306976 [details]
xorg.conf after running system-config-display
Comment 6 Terry Riley 2008-05-28 15:22:04 EDT
Created attachment 306977 [details]
/var/log/gdm/:0.log
Comment 7 Petr Tuma 2008-08-13 04:10:51 EDT
I'm encountering the same problem (on the same hardware too), except my Xorg.log after the crash seems different (attached). Also, rarely, this problem occurs on the first boot (no need to logout and login), and this seems to be more likely to happen if the boot is after a power off & on cycle used to get from previous crash.
Comment 8 Petr Tuma 2008-08-13 04:11:44 EDT
Created attachment 314175 [details]
Xorg.log collected after the crash ...
Comment 9 Petr Tuma 2008-09-18 14:59:19 EDT
This bug has disappeared after the recent bunch of Fedora 9 updates (kernel 2.6.26-3.29, does not look like there was any change in Xorg packages). If the other reporter sees the same, the bug can be closed.
Comment 10 Terry Riley 2008-09-18 15:15:08 EDT
Problem has disappeared.

Note You need to log in before you can comment on or make changes to this bug.