Bug 446744 - HA-LVM: Will not start on ia64, looking for initrd in wrong directory.
HA-LVM: Will not start on ia64, looking for initrd in wrong directory.
Status: CLOSED WONTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On: 446260
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 16:11 EDT by Jonathan Earl Brassow
Modified: 2009-04-16 15:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 15:18:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2008-05-15 16:11:20 EDT
+++ This bug was initially created as a clone of Bug #446260 +++

Description of problem:

HA-LVM will not run on ia64 due to the lvm.sh script looking for initrd in /boot
rather than /boot/efi/efi/redhat.   The resulting error in /var/log/messages is:
 May 13 14:26:42 link-14 clurgmgrd: [5556]: <err> HA LVM requires the initrd
image to be newer than lvm.conf


From lvm.sh:

 # Fixme: we might be able to perform a better check...
        if [ "$(find /boot/*.img -newer /etc/lvm/lvm.conf)" == "" ]; then
                ocf_log err "HA LVM requires the initrd image to be newer than
lvm.conf"
                return $OCF_ERR_GENERIC
        fi


The path in the find needs to be changed for ia64 or something along the lines of:

find /boot -name *.img -newer /etc/lvm/lvm.conf

which should work on all archs.

That find seems a bit suspect as well, as it finds any initrd which is newer
than lvm.conf.  Shouldn't it check the one you booted with is newer?

-- Additional comment from jbrassow@redhat.com on 2008-05-14 14:08 EST --
"That find seems a bit suspect as well, as it finds any initrd which is newer
than lvm.conf.  Shouldn't it check the one you booted with is newer?"

Yes, it should; but how do you find out which initrd was used?  I suppose you
could look in grub... gets a bit crazy.  Perhaps we can start with your suggestion.
Comment 1 Dean Jansa 2008-07-18 15:14:32 EDT
The check is still looking in the wrong spot in ia64:


lvm.sh: if [ "$(find /boot/*.img -newer /etc/lvm/lvm.conf)" == "" ]; then

rgmanager-1.9.80-1
RHEL4-U7-re20080703.3 tree

Comment 2 Chris Feist 2009-03-12 16:24:38 EDT
Re-opening due to comment #1 from dean.
Comment 3 Jonathan Earl Brassow 2009-04-08 15:18:34 EDT
won't fix in rhel4.... although, a simple test seems to suggest that the current code works already:

[root@z3 ~]# touch /boot/efi/efi/redhat/initrd-2.6.18-128.el5.img
[root@z3 ~]# if [ "$(find /boot -name *.img -newer /etc/lvm/lvm.conf)" == "" ]; then echo bad; else echo good; fi
good
[root@z3 ~]# touch /etc/lvm/lvm.conf
[root@z3 ~]# if [ "$(find /boot -name *.img -newer /etc/lvm/lvm.conf)" == "" ]; then echo bad; else echo good; fi
bad
[root@z3 ~]#

Note You need to log in before you can comment on or make changes to this bug.