Bug 446805 - kdevelop: CVS integration not present (RFE)
kdevelop: CVS integration not present (RFE)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdevelop (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 04:03 EDT by The Source
Modified: 2008-07-06 15:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-06 15:38:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Source 2008-05-16 04:03:07 EDT
Description of problem:
Vanished in Fedora 9. Worked fine in Fedora 8.

Version-Release number of selected component (if applicable):
3.5.1-4.fc9.i386


How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2008-05-16 07:42:48 EDT
kdevelop requires kdesdk version 3 for this, which isn't present in F9 (kdesdk
version 4 is).
Comment 2 The Source 2008-05-16 07:50:38 EDT
Will kdevelop 4 support CVS with kdesdk 4?
Comment 3 Rex Dieter 2008-05-16 08:15:48 EDT
presumably,yes.
Comment 4 Rex Dieter 2008-05-16 08:16:39 EDT
we can keep this open as a feature request, could be possible to include the
parts of kdesdk3 to make things work here.
Comment 5 Kevin Kofler 2008-05-16 18:18:43 EDT
The problem is that it's not just a KDE 3 library, it depends on a KDE 3 
service (cvsservice) too. The apps talk to that service through DCOP. I'm not 
sure that service, if we installed it, would get started properly in KDE 4. 
(Does this feature work in a non-KDE desktop? If not, it probably won't work in 
KDE 4 either.)
Comment 6 Kevin Kofler 2008-05-16 18:22:48 EDT
Actually, the KDE 4 cvsservice exports a D-Bus interface almost identical to 
the KDE 3 DCOP interface, it might be possible to hack KDevelop to use that 
D-Bus interface through qt3-dbus.
Comment 7 Kevin Kofler 2008-05-16 18:31:59 EDT
Actually, the KDE 3 service is started by this:
>    if (KApplication::startServiceByDesktopName("cvsservice",
>        QStringList(), &error, &appId))
so I guess it would work with the KDE 3 one.

And patching things to the KDE 4 one sounds like a lot of work, the KDevelop 
cvsservice integration is almost 500 KB of code. :-(
Comment 8 Steven M. Parrish 2008-06-23 17:03:05 EDT
Based on the above comments should this be closed as WONTFIX?
Comment 9 Kevin Kofler 2008-06-23 17:32:10 EDT
Well, in principle we could package a kdesdk3 or cvsservice3...

Note You need to log in before you can comment on or make changes to this bug.