Bug 446857 - Chapter 3 command line example is incorrect.
Chapter 3 command line example is incorrect.
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Messaging_Installation_and_Configuration_Guide (Show other bugs)
beta
All Linux
medium Severity high
: ---
: ---
Assigned To: Lana Brindley
Kim van der Riet
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 10:16 EDT by William Henry
Modified: 2013-10-23 19:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 01:53:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Henry 2008-05-16 10:16:56 EDT
Description of problem:

In Chapter 3 of the install guide it says:

# /usr/sbin/rhmd -t --load-module <libbdbstore.so> log-output=/var/log/qpidd.log

Two issues:

1) It needs to either say before that that the right libdbstore.so file needs to
substituted here between the '<' '>' e.g. libdbstore.so.0 or explicitly show
libdbstore.so.0 in the command above.  (The example is already giving an
explicit example for log-output.)

2) log-output=/var/log/qpidd.log does not work. (it's for congif file) According
to --help it should be --log-out FILE so --log-output /var/log/qpidd.log (no '='
either)
It seems that the config parameters got copied up to the command line and then
someone forgot to change it.

BTW is it worth mentioning at the start of this chapter that you should (still)
be root?

Of course there are times when you want to run from the command line but PERHAPS
the guide should encourage the use of 'service' and config files only???

I think it ought to explain both. Because there are times you might want to run
from the command line (e.g. debugging something)
??

Version-Release number of selected component (if applicable):
beta

How reproducible:
Run the above command from the install guide.

Steps to Reproduce:
1.  Be root
2.  Run the command as stated above from guide.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lana Brindley 2008-05-21 21:32:46 EDT
Some great spots here ... thanks!

Comments inline:

(In reply to comment #0)
> Description of problem:
> 
> In Chapter 3 of the install guide it says:
> 
> # /usr/sbin/rhmd -t --load-module <libbdbstore.so> log-output=/var/log/qpidd.log
> 
> Two issues:
> 
> 1) It needs to either say before that that the right libdbstore.so file needs to
> substituted here between the '<' '>' e.g. libdbstore.so.0 or explicitly show
> libdbstore.so.0 in the command above.  (The example is already giving an
> explicit example for log-output.)
> 
> 2) log-output=/var/log/qpidd.log does not work. (it's for congif file) According
> to --help it should be --log-out FILE so --log-output /var/log/qpidd.log (no '='
> either)
> It seems that the config parameters got copied up to the command line and then
> someone forgot to change it.


Updated to:
<screen>
# /usr/sbin/rhmd -t --load-module <replaceable>libbdbstore.so</replaceable>
--log-output <replaceable>/var/log/qpidd.log</replaceable>
</screen>


> 
> BTW is it worth mentioning at the start of this chapter that you should (still)
> be root?

In theory, the "#" should be enough, especially as it is explicitly mentioned
earlier in the book. However, if it slipped you up, it's worth mentioning it again.
Updated to:

<para>
	To set options for a single instance, add the option to the command line when
you start the broker. You will need to be the root user.
</para>

> 
> Of course there are times when you want to run from the command line but PERHAPS
> the guide should encourage the use of 'service' and config files only???
> 
> I think it ought to explain both. Because there are times you might want to run
> from the command line (e.g. debugging something)
> ??

I like it explaining both. However, it made me think ... we could put the config
file instructions first, *then* the CLI instructions. 

What do you think?

Thanks :)

LKB
Comment 2 William Henry 2008-05-22 08:02:21 EDT
I think it's more common to show the command line instructions first and then
show how it can be "automated" using a configuration file.  (Might be a bad
convention, though ;-)   

I think whichever is the most common or recommended way ought to go first.  So
perhaps you are right: config first followed by a "Of course you can also run
the daemon from the command line ..."

William

Note You need to log in before you can comment on or make changes to this bug.