This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 446897 - python-qpid-tests fail to find amqp spec xml file
python-qpid-tests fail to find amqp spec xml file
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid (Show other bugs)
beta
All Linux
low Severity low
: Next Version
: ---
Assigned To: Rafael H. Schloming
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 11:50 EDT by Andrew Stitcher
Modified: 2014-12-01 18:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-28 10:49:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Stitcher 2008-05-16 11:50:34 EDT
Description of problem:

When you run python-qpid-tests from the command line you get an error because
the script is looking in the wrong place for the amqp spec xml file.
Incidentally it appears to be looking for the wrong file as well.

It should be using the qpid_config.py file like the other python qpid tools.

Version-Release number of selected component (if applicable):

python-qpid-0.2.656025

How reproducible:

Completely

Steps to Reproduce:
1. run "python-qpid-tests"
2.
3.
  
Actual results:

[astitche@qpid-test3 qpid-testing]$ python-qpid-tests 
Traceback (most recent call last):
  File "/usr/bin/python-qpid-tests", line 32, in ?
    if not testrunner.run(): sys.exit(1)
  File "/usr/lib/python2.4/site-packages/qpid/testlib.py", line 176, in run
    self._parseargs(args)
  File "/usr/lib/python2.4/site-packages/qpid/testlib.py", line 148, in _parseargs
    self.spec = qpid.spec.load(self.specfile, *self.errata)
  File "/usr/lib/python2.4/site-packages/qpid/spec.py", line 50, in load
    raise IOError("No such file or directory: '%s'" % name)
IOError: No such file or directory: '../specs/amqp.0-8.xml'

Expected results:

It's supposed to run the tests!

Additional info:
Comment 1 Rafael H. Schloming 2009-10-28 10:49:49 EDT
This testrunner has been replaced.

Note You need to log in before you can comment on or make changes to this bug.