Bug 446919 - ocaml-gettext (-devel) dependencies are all wrong
ocaml-gettext (-devel) dependencies are all wrong
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ocaml-gettext (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 12:50 EDT by Richard W.M. Jones
Modified: 2008-05-27 08:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 08:21:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2008-05-16 12:50:23 EDT
ocaml-gettext and ocaml-gettext-devel packages don't have
sufficient run-time dependencies to work in most cases.

virt-df (http://www.annexia.org/tmp/ocaml/virt-df.spec)
needed:

# Tortuous list of BRs for gettext.
BuildRequires:  ocaml-gettext-devel >= 0.3.0
BuildRequires:  ocaml-fileutils-devel
%ifnarch ppc64
BuildRequires:  ocaml-camomile-data
%endif

There are several probable issues here:

(1) The standalone ocaml-gettext program needs camomile
data files, but only if it was compiled with camomile.
(ie. currently not on ppc64).

(2) fileutils.cmxa is required by any program which links
with gettext-stubs library, thus ocaml-gettext-devel should
require ocaml-fileutils-devel.  (This may be a more
systematic problem with the automatic dependency
generator in the base OCaml module, since it doesn't
cover native libraries, but should).
Comment 1 Richard W.M. Jones 2008-05-27 08:21:13 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=630252

Note You need to log in before you can comment on or make changes to this bug.