Bug 446966 - [RHEL4/Evo28] crash in camel_message_info_ptr at camel-folder-summary.c
[RHEL4/Evo28] crash in camel_message_info_ptr at camel-folder-summary.c
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution28 (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Barnes
Matthew Barnes
:
Depends On:
Blocks: 442631
  Show dependency treegraph
 
Reported: 2008-05-16 15:27 EDT by ritz
Modified: 2010-10-22 21:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-26 17:30:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 499975 None None None Never

  None (edit)
Description ritz 2008-05-16 15:27:38 EDT
Description of problem:
evolution segfaults. User started evolution without the --offline option, when
he saw a SIGSEGV on evolution.

Version-Release number of selected component (if applicable):
evolution28-atk-1.12.2-4.el4-i386
evolution28-gtk2-debuginfo-2.10.4-21.el4-i386
evolution28-evolution-data-server-1.8.0-41.el4-i386
evolution28-cairo-1.2.4-6.el4-i386
evolution28-atk-debuginfo-1.12.2-4.el4-i386
evolution28-glib2-debuginfo-2.12.3-6.el4-i386
evolution28-cairo-debuginfo-1.2.4-6.el4-i386
evolution28-2.8.0-59.el4-i386
evolution28-evolution-data-server-debuginfo-1.8.0-41.el4-i386
evolution28-pango-1.14.9-7.el4-i386
evolution28-gtk2-2.10.4-21.el4-i386
evolution28-gtkhtml3-debuginfo-3.12.0-9.el4-i386
evolution28-pango-debuginfo-1.14.9-7.el4-i386
evolution28-libsoup-debuginfo-2.2.98-5.el4-i386
evolution28-debuginfo-2.8.0-59.el4-i386
evolution28-evolution-connector-debuginfo-2.8.0-17.el4-i386
evolution28-libsoup-2.2.98-5.el4-i386
evolution28-evolution-connector-2.8.0-17.el4-i386
evolution28-glib2-2.12.3-6.el4-i386
evolution28-gtkhtml3-3.12.0-11.el4-i386


How reproducible:
random

Steps to Reproduce:
n/a
  
Actual results:
SEGV

Expected results:
Evolution should not crash

Additional info:
Probable upstream bug - http://bugzilla.gnome.org/show_bug.cgi?id=499975

(gdb) thread 2
[Switching to thread 2 (process 6409)]#0  0x0086effa in camel_message_info_ptr
(mi=0x90d6d28, id=0)
    at camel-folder-summary.c:2966
2966			return ((CamelFolderSummaryClass *)((CamelObject
*)mi->summary)->klass)->info_ptr(mi, id);
(gdb) bt
#0  0x0086effa in camel_message_info_ptr (mi=0x90d6d28, id=0) at
camel-folder-summary.c:2966
#1  0x0086f086 in message_info_save (s=0x90c5fa0, out=0x90d7898, info=0x90d6d28)
at camel-folder-summary.c:1917
#2  0x00b2f6bf in message_info_save (summary=0x90c5fa0, out=0x90d7898,
info=0x90d6d28) at camel-exchange-summary.c:200
#4  0x00b2b955 in camel_exchange_folder_construct (folder=0x90c5ce8,
parent=0x8bd6498, name=0x90c8649 "personal/HP-SIM", 
#3  0x0086cb87 in camel_folder_summary_save (s=0x90c5fa0) at
camel-folder-summary.c:721
    camel_flags=0, 
    folder_dir=0x90cb090
"/home/nstuyt/.evolution/mail/exchange/nstuyt@zcarhxm1.ca.nortel.com/personal/subfolders/HP-SIM",

    offline_state=0, stub=0x8fcb2a8, ex=0x0) at camel-exchange-folder.c:1120
#5  0x00b2ddea in exchange_get_folder (store=0x8bd6498, folder_name=0x90c8649
"personal/HP-SIM", flags=0, ex=0x0)
    at camel-exchange-store.c:508
#6  0x00888853 in camel_store_get_folder (store=0x8bd6498, folder_name=0x90c8649
"personal/HP-SIM", flags=0, ex=0x0)
    at camel-store.c:260
#7  0x01de3942 in mail_tools_x_evolution_message_parse ()
   from /usr/evolution28/lib/evolution/2.8/components/libevolution-mail.so
#8  0x01ddf43f in dialog_map () from
/usr/evolution28/lib/evolution/2.8/components/libevolution-mail.so
#9  0x01dd987c in mail_enable_stop () from
/usr/evolution28/lib/evolution/2.8/components/libevolution-mail.so
#10 0x0067ee2c in thread_dispatch (din=0xe) at e-msgport.c:1025
#11 0x001533cc in start_thread () from /lib/tls/libpthread.so.0
#12 0x0228d1ae in clone () from /lib/tls/libc.so.6


valgrind, coredump, sysreport and more attached.
Comment 1 ritz 2008-05-16 15:27:42 EDT
Created attachment 305729 [details]
coredump and valgrind o/p
Comment 7 Matthew Barnes 2008-07-01 13:18:54 EDT
Marking attachment
evolution28-2.8.0-59.el4-evolution-SEGVd.navigating.folders.tgz as obsolete
since the stack traces show no evidence of a crash.
Comment 8 Matthew Barnes 2008-07-01 13:21:23 EDT
Marking attachment evolution28-2.8.0-59.el4-evolution-SEGVd.tgz as obsolete
since the stack traces show no evidence of a crash.
Comment 9 Matthew Barnes 2008-07-01 13:23:56 EDT
Marking attachment
evolution28-2.8.0-59.el4-evolution-SEGVd.was.doing.nothing.tgz as obsolete since
the stack traces show no evidence of a crash.
Comment 10 Matthew Barnes 2008-07-01 13:25:05 EDT
Setting status to NEEDINFO until a stack traces showing the segmentation fault
is provided.
Comment 11 Issue Tracker 2008-07-07 13:26:42 EDT
odd. the attachment attached to bugzilla shows a SEGV. the trace is
attached to bugzilla.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1267729504 (LWP 6409)]
0x0086effa in camel_message_info_ptr (mi=0x90d6d28, id=0)
    at camel-folder-summary.c:2966
2966                    return ((CamelFolderSummaryClass *)((CamelObject
*)mi->summary)->klass)->info_ptr(mi, id);


am i missing out on anything here ?

-- ritz

Internal Status set to 'Waiting on Engineering'

This event sent from IssueTracker by rkhadgar 
 issue 180031
Comment 12 RHEL Product and Program Management 2008-09-05 13:09:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 15 RHEL Product and Program Management 2008-09-26 17:30:34 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.