Bug 446981 - gnome-keyring-daemon not started even if "launch gnome services" is checked
gnome-keyring-daemon not started even if "launch gnome services" is checked
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xfce4-session (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
http://bugzilla.xfce.org/show_bug.cgi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 16:01 EDT by Matthew Miller
Modified: 2009-05-02 12:24 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.4.3-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-02 12:24:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2008-05-16 16:01:57 EDT
Description of problem:

The gnome-keyring-daemon is, among other things, a slick version of ssh-agent.
I'd like it to be running, ideally replacing the default ssh-agent.


Version-Release number of selected component (if applicable):

xfce-utils-4.4.2-4.fc9.x86_64

How reproducible:

always

Steps to Reproduce:
1. Go to Sessions and Startup configuration applet
2. In the Advanced Tab, check "Launch Gnome services on startup"
3. Log out, log in again
  
Actual results:

There it isn't.

Expected results:

gnome-keyring-daemon running
Additional info:
Comment 1 Kevin Fenzi 2008-05-16 16:15:15 EDT
Odd it's working here... 

Is 'gnome-keyring' installed?

Is there any errors in ~/.xsession-errors?

Did you save your session to make sure your session change persists. 
Comment 2 Christoph Wickert 2008-08-27 00:50:19 EDT
See http://bugzilla.xfce.org/show_bug.cgi?id=3007#c2
Comment 3 Kevin Fenzi 2008-09-08 18:04:32 EDT
Thats interesting, but seems to be only in the case of pam_keyring being installed/used. 

Matthew: Are you using pam_keyring? 
Do you still see this bug? Can you provide the info requested in comment #1?
Comment 4 Matthew Miller 2008-09-09 15:33:18 EDT
I just did a fresh Rawhide install, and it seems that gnome-keyring-daemon is now started. However, it's still not working on my older rawhide system. (Ahh, the joys of development distros...)

Also, the xfce session is still run under a separate ssh-agent; wouldn't it make sense to consolidate when possible?
Comment 5 Kevin Fenzi 2008-09-09 17:21:47 EDT
Does it happen under a new user? 

It seems like some oddness in your rawhide user account? 
Try mv'ing ~/.config and/or ~/.cache and see if that helps? 

In any case, I can't reproduce it, so I don't think it's really a Xfce bug... 
Can we go ahead and close this now?
Comment 6 Christoph Wickert 2008-09-09 19:02:59 EDT
Sorry, wanted to comment on this one earlier...
(In reply to comment #5)
> Try mv'ing ~/.config and/or ~/.cache and see if that helps? 

I think 'rm -rf ~/.cache/session' should be sufficient, maybe move .config/xfce4-session/ out of the way too.
Comment 7 Kevin Fenzi 2009-01-24 22:45:33 EST
Matthew: Now that 4.6b3 has landed in rawhide, can you confirm it's fixed there?

The new code should do the right thing and re-use an existing keyring daemon... so I think it should be fixed. 
Can you confirm?
Comment 8 Fedora Update System 2009-04-13 07:13:05 EDT
xfdesktop-4.4.3-1.fc9,gtk-xfce-engine-2.4.3-1.fc9,xfce4-icon-theme-4.4.3-1.fc9,orage-4.4.3-1.fc9,xfwm4-themes-4.4.3-1.fc9,xfce4-mixer-4.4.3-3.fc9,Thunar-0.9.3-1.fc9,Terminal-0.2.8.3-1.fc9,xfce4-session-4.4.3-1.fc9,xfce-utils-4.4.3-1.fc9,xfwm4-4.4.3-2.fc9,xfce4-panel-4.4.3-1.fc9,exo-0.3.4-3.fc9,xfce-mcs-plugins-4.4.3-1.fc9,xfce-mcs-manager-4.4.3-1.fc9.1,xfce4-appfinder-4.4.3-1.fc9,mousepad-0.2.14-1.fc9,libxfce4mcs-4.4.3-1.fc9,libxfcegui4-4.4.3-1.fc9,libxfce4util-4.4.3-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xfdesktop-4.4.3-1.fc9,gtk-xfce-engine-2.4.3-1.fc9,xfce4-icon-theme-4.4.3-1.fc9,orage-4.4.3-1.fc9,xfwm4-themes-4.4.3-1.fc9,xfce4-mixer-4.4.3-3.fc9,Thunar-0.9.3-1.fc9,Terminal-0.2.8.3-1.fc9,xfce4-session-4.4.3-1.fc9,xfce-utils-4.4.3-1.fc9,xfwm4-4.4.3-2.fc9,xfce4-panel-4.4.3-1.fc9,exo-0.3.4-3.fc9,xfce-mcs-plugins-4.4.3-1.fc9,xfce-mcs-manager-4.4.3-1.fc9.1,xfce4-appfinder-4.4.3-1.fc9,mousepad-0.2.14-1.fc9,libxfce4mcs-4.4.3-1.fc9,libxfcegui4-4.4.3-1.fc9,libxfce4util-4.4.3-1.fc9
Comment 9 Fedora Update System 2009-04-13 15:34:08 EDT
xfdesktop-4.4.3-1.fc9, gtk-xfce-engine-2.4.3-1.fc9, xfce4-icon-theme-4.4.3-1.fc9, orage-4.4.3-1.fc9, xfwm4-themes-4.4.3-1.fc9, xfce4-mixer-4.4.3-3.fc9, Thunar-0.9.3-1.fc9, Terminal-0.2.8.3-1.fc9, xfce4-session-4.4.3-1.fc9, xfce-utils-4.4.3-1.fc9, xfwm4-4.4.3-2.fc9, xfce4-panel-4.4.3-1.fc9, exo-0.3.4-3.fc9, xfce-mcs-plugins-4.4.3-1.fc9, xfce-mcs-manager-4.4.3-1.fc9.1, xfce4-appfinder-4.4.3-1.fc9, mousepad-0.2.14-1.fc9, libxfce4mcs-4.4.3-1.fc9, libxfcegui4-4.4.3-1.fc9, libxfce4util-4.4.3-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update xfdesktop gtk-xfce-engine xfce4-icon-theme orage xfwm4-themes xfce4-mixer Thunar Terminal xfce4-session xfce-utils xfwm4 xfce4-panel exo xfce-mcs-plugins xfce-mcs-manager xfce4-appfinder mousepad libxfce4mcs libxfcegui4 libxfce4util'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3521
Comment 10 Fedora Update System 2009-05-02 12:23:45 EDT
xfdesktop-4.4.3-1.fc9, gtk-xfce-engine-2.4.3-1.fc9, xfce4-icon-theme-4.4.3-1.fc9, orage-4.4.3-1.fc9, xfwm4-themes-4.4.3-1.fc9, xfce4-mixer-4.4.3-3.fc9, Thunar-0.9.3-1.fc9, Terminal-0.2.8.3-1.fc9, xfce4-session-4.4.3-1.fc9, xfce-utils-4.4.3-1.fc9, xfwm4-4.4.3-2.fc9, xfce4-panel-4.4.3-1.fc9, exo-0.3.4-3.fc9, xfce-mcs-plugins-4.4.3-1.fc9, xfce-mcs-manager-4.4.3-1.fc9.1, xfce4-appfinder-4.4.3-1.fc9, mousepad-0.2.14-1.fc9, libxfce4mcs-4.4.3-1.fc9, libxfcegui4-4.4.3-1.fc9, libxfce4util-4.4.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.