Bug 447058 - Totem-xine doesn't get automatically priority over the default gstreamer one
Totem-xine doesn't get automatically priority over the default gstreamer one
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 09:57 EDT by Peeter Puusemp
Modified: 2008-05-17 12:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-17 11:37:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peeter Puusemp 2008-05-17 09:57:10 EDT
Description of problem:
Totem-xine doesn't get automatically priority over the default gstreamer one
after the totem-xine installation. It should be how the xine engine can be
enabled as I heard, isn't it?

Version-Release number of selected component (if applicable):
The latest available.

How reproducible:
Install totem-xine.
Comment 1 Bastien Nocera 2008-05-17 10:46:33 EDT
GStreamer should have priority:
/usr/sbin/alternatives --install %{_libdir}/libbaconvideowidget.so.0.0.0
totem-backend %{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0 2
compared to:
/usr/sbin/alternatives --install %{_libdir}/libbaconvideowidget.so.0.0.0
totem-backend %{_libdir}/libbaconvideowidget-xine.so.0.0.0 1

Did you upgrade from an earlier F9 test, or rawhide to a full F9?
Comment 2 Stewart Adam 2008-05-17 10:47:35 EDT
Because the two backends play nice now in F9, the totem-backend tool can be used
to change priorities:
#  su -
#  totem-backend -b xine
Or to change the backend for a single run (this does not require root privileges):
#  totem-backend -b xine totem
Comment 3 Peeter Puusemp 2008-05-17 11:21:54 EDT
Thank you, Stewart! That works.

Bastien, I made a clean install.

I am not the only one who had problems enabling the xine engine in F9:
http://www.fedoraforum.org/forum/showthread.php?t=188586

It would be much easier to users if it could be available to choose from Totem's
menu (grayed out when totem-xine is not installed or added after totem-xine
installation for example). Then it would be also easier to switch between the
GStreamer and xine engine. At the moment the information how to enable the xine
engine will be available only on how-to sites.
Comment 4 Bastien Nocera 2008-05-17 11:37:16 EDT
Oh right. I misunderstood the problem. Note that "how to" enable the xine
backend is explained in the release notes... which nobody reads, ever.

http://docs.fedoraproject.org/release-notes/f9/en_US/sn-Multimedia.html#sn-Multimedia-Players

Feel free to point people to it. I also sent a mail to fedorafaq.org some time
ago about this, but they haven't updated for Fedora 9 yet.
Comment 5 Peeter Puusemp 2008-05-17 12:04:32 EDT
I read it, but not through as it is too long. My bad. Sorry for that.

Thank you for pointing it out.

I still think that this method is not visible to users, but it seems to be
already discussed:
http://fedoraproject.org/wiki/FWN/Issue105#head-540aea95670a0eda7b830ed6e66004344dcbf99b

Good luck!

Note You need to log in before you can comment on or make changes to this bug.