Bug 447093 - Crash in OOImpress
Crash in OOImpress
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 16:33 EDT by Matěj Cepl
Modified: 2018-04-11 06:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-05 05:52:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Impress presentation (926.95 KB, application/vnd.oasis.opendocument.presentation)
2008-05-17 16:33 EDT, Matěj Cepl
no flags Details
Drawing file (278.39 KB, application/vnd.oasis.opendocument.graphics)
2008-05-17 16:35 EDT, Matěj Cepl
no flags Details
Stack Trace and ldd of swriter (11.66 KB, text/plain)
2008-06-02 06:41 EDT, Steve Dowe
no flags Details

  None (edit)
Description Matěj Cepl 2008-05-17 16:33:54 EDT
Description of problem:

I was closing a huge embedded ODG drawing in OOImpress presentation (will be
attached -- tomorrow's prayer for my chuch ;-)).

(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers//intel_drv.so
(II) Loading /usr/lib/xorg/modules/drivers//intel_master_drv.so
(==) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: GNOME
(IV)   openoffice.org-kde version is: balíček openoffice.org-kde není nainstalován
(V)    libgcj version is: libgcj-4.3.0-8-i386
(IV)   kernel is: Linux 2.6.25.3-18.fc9.i686 #1 SMP Tue May 13 05:38:53 EDT 2008
i686 i686 i386
(VII)  OpenOffice.org core rpm version is: openoffice.org-core-2.4.0-12.8.fc9-i386
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora release 9 (Sulphur)
(VV)   LANG is: cs_CZ.UTF-8
...start free space details ...
Souborový systém      1K bloků   Použité     Volné Uži% Připojeno do
/dev/mapper/home      70538156  31848920  35106084  48% /home
tmpfs                   513204     29528    483676   6% /tmp
...end free space details ...
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          permissive
Policy version:                 22
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x46ad3e8: 0x1c4c7c: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x253e8
0x46add23: 0x1c4c7c: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x25d23
0x110400: 0x0:  + 0x400 (__kernel_sigreturn + 0x0)
0x217eb4d: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x17eb4d
0x8f4b843: 0x529b0: /usr/lib/openoffice.org/program/libembobj.so + 0x26843
(OCommonEmbeddedObject::Deactivate() + 0xd7)
0x8f4c1ea: 0x529b0: /usr/lib/openoffice.org/program/libembobj.so + 0x271ea
(OCommonEmbeddedObject::SwitchStateTo_Impl(long) + 0x83e)
0x8f4c954: 0x529b0: /usr/lib/openoffice.org/program/libembobj.so + 0x27954
(OCommonEmbeddedObject::changeState(long) + 0x1ec)
0x217c473: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x17c473
(SfxInPlaceClient::DeactivateObject() + 0x1e7)
0x3ff079f: 0x52641c: /usr/lib/openoffice.org/program/libsd680li.so + 0x10479f
0x40188da: 0x52641c: /usr/lib/openoffice.org/program/libsd680li.so + 0x12c8da
0x3595035: 0xbcd468: /usr/lib/openoffice.org/program/libsvx680li.so + 0x29a035
(SdrMarkView::UnmarkAllObj(SdrPageView*) + 0x73)
0x35c88f0: 0xbcd468: /usr/lib/openoffice.org/program/libsvx680li.so + 0x2cd8f0
(SdrView::UnmarkAll() + 0x9e)
0x41c5fc3: 0x52641c: /usr/lib/openoffice.org/program/libsd680li.so + 0x2d9fc3
0x3fe6630: 0x52641c: /usr/lib/openoffice.org/program/libsd680li.so + 0xfa630
0x3ff71ac: 0x52641c: /usr/lib/openoffice.org/program/libsd680li.so + 0x10b1ac
0x3fec346: 0x52641c: /usr/lib/openoffice.org/program/libsd680li.so + 0x100346
0x4a5f4f4: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x20a4f4
0x4a60d15: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x20bd15
0x4a5fa2b: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x20aa2b
0xe2f337: 0x4b950: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x33337
0xe2c508: 0x4b950: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x30508
0x797713e: 0x3fc9f8: /usr/lib/libgtk-x11-2.0.so.0 + 0x17813e
0x85612b: 0x3f544: /lib/libgobject-2.0.so.0 + 0x912b (g_closure_invoke + 0x1ab)
0x86a995: 0x3f544: /lib/libgobject-2.0.so.0 + 0x1d995
0x86bd58: 0x3f544: /lib/libgobject-2.0.so.0 + 0x1ed58 (g_signal_emit_valist + 0x688)
0x86c336: 0x3f544: /lib/libgobject-2.0.so.0 + 0x1f336 (g_signal_emit + 0x26)
0x7ae8928: 0x3fc9f8: /usr/lib/libgtk-x11-2.0.so.0 + 0x2e9928
0x7ae8450: 0x3fc9f8: /usr/lib/libgtk-x11-2.0.so.0 + 0x2e9450 (gtk_widget_event +
0x115)
0x79756fb: 0x3fc9f8: /usr/lib/libgtk-x11-2.0.so.0 + 0x1766fb
(gtk_propagate_event + 0x260)
0x79741aa: 0x3fc9f8: /usr/lib/libgtk-x11-2.0.so.0 + 0x1751aa (gtk_main_do_event
+ 0x29f)
0x6f7cfc0: 0x94978: /usr/lib/libgdk-x11-2.0.so.0 + 0x4cfc0
0x663098: 0xe0108: /lib/libglib-2.0.so.0 + 0x37098 (g_main_context_dispatch + 0x1e8)
0x666743: 0xe0108: /lib/libglib-2.0.so.0 + 0x3a743
0x666901: 0xe0108: /lib/libglib-2.0.so.0 + 0x3a901 (g_main_context_iteration + 0x71)
0xe0d84f: 0x4b950: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x1184f
0xef78b9: 0x7859c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x4b8b9 (X11SalInstance::Yield(bool, bool) + 0x2f)
0x48edcb9: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x98cb9
(Application::Yield(bool) + 0x57)
0x48edd07: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x98d07
(Application::Execute() + 0x2b)
0x71d8933: 0x77340: /usr/lib/openoffice.org/program/libsoffice.so + 0x2f933
(desktop::Desktop::Main() + 0x1a0b)
0x48f12c2: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9c2c2
0x48f145e: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9c45e
(SVMain() + 0x2c)
0x71ccf01: 0x77340: /usr/lib/openoffice.org/program/libsoffice.so + 0x23f01
(main + 0xe5)
0x4565d6: 0x164d7c: /lib/libc.so.6 + 0x165d6 (__libc_start_main + 0xe6)
0x80484f1: 0x6dc: /usr/lib/openoffice.org/program/simpress.bin + 0x4f1 (main + 0x51)
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x00110000)
	libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x0043e000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00162000)
	libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x001f8000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00215000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x00232000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x0023c000)
	libcairo.so.2 => /usr/lib/libcairo.so.2 (0x0027f000)
	libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x002ee000)
	libdl.so.2 => /lib/libdl.so.2 (0x002f2000)
	libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x002f7000)
	librt.so.1 => /lib/librt.so.1 (0x002fc000)
	libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0x00306000)
	libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x00324000)
	libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x00365000)
	libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x0083e000)
	libvclplug_gen680li.so =>
/usr/lib/openoffice.org/program/libvclplug_gen680li.so (0x0091f000)
	libvcl680li.so => /usr/lib/openoffice.org/program/libvcl680li.so (0xb7ca3000)
	libpsp680li.so => /usr/lib/openoffice.org/program/libpsp680li.so (0x0099e000)
	libsot680li.so => /usr/lib/openoffice.org/program/libsot680li.so (0x003a5000)
	libutl680li.so => /usr/lib/openoffice.org/program/libutl680li.so (0x00a7f000)
	libtl680li.so => /usr/lib/openoffice.org/program/libtl680li.so (0x00b05000)
	libcomphelp4gcc3.so => /usr/lib/openoffice.org/program/libcomphelp4gcc3.so
(0x00ba8000)
	libucbhelper4gcc3.so => /usr/lib/openoffice.org/program/libucbhelper4gcc3.so
(0x00ca5000)
	libuno_cppuhelpergcc3.so.3 =>
/usr/lib/openoffice.org/program/libuno_cppuhelpergcc3.so.3 (0xb7c0d000)
	libuno_cppu.so.3 => /usr/lib/openoffice.org/program/libuno_cppu.so.3 (0xb7bdf000)
	libvos3gcc3.so => /usr/lib/openoffice.org/program/libvos3gcc3.so (0xb7bba000)
	libuno_sal.so.3 => /usr/lib/openoffice.org/program/libuno_sal.so.3 (0xb79ee000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0xb78ed000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x00403000)
	libpthread.so.0 => /lib/libpthread.so.0 (0xb78d4000)
	libstlport_gcc.so => /usr/lib/openoffice.org/program/libstlport_gcc.so (0xb7809000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7717000)
	libm.so.6 => /lib/libm.so.6 (0xb76ed000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00d10000)
	libc.so.6 => /lib/libc.so.6 (0xb7584000)
	libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x00413000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00416000)
	libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb755d000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb752d000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb7524000)
	libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x0041b000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0xb751b000)
	libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb7514000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb7509000)
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb74df000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb7450000)
	libz.so.1 => /lib/libz.so.1 (0xb743c000)
	libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb740f000)
	libselinux.so.1 => /lib/libselinux.so.1 (0xb73f2000)
	/lib/ld-linux.so.2 (0x00420000)
	libnsl.so.1 => /lib/libnsl.so.1 (0xb73d8000)
	libcap.so.2 => /lib/libcap.so.2 (0x00d1e000)
	libSM.so.6 => /usr/lib/libSM.so.6 (0xb73cf000)
	libICE.so.6 => /usr/lib/libICE.so.6 (0xb73b5000)
	libi18nisolang1gcc3.so =>
/usr/lib/openoffice.org/program/libi18nisolang1gcc3.so (0xb73ae000)
	libbasegfx680li.so => /usr/lib/openoffice.org/program/libbasegfx680li.so
(0xb7358000)
	libicuuc.so.38 => /usr/lib/libicuuc.so.38 (0xb7224000)
	libicule.so.38 => /usr/lib/libicule.so.38 (0xb71ed000)
	libjvmaccessgcc3.so.3 => /usr/lib/openoffice.org/program/libjvmaccessgcc3.so.3
(0xb71e6000)
	libjvmfwk.so.3 => /usr/lib/openoffice.org/program/libjvmfwk.so.3 (0xb71ca000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org/program/libuno_salhelpergcc3.so.3 (0xb71c6000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0xb7194000)
	libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0x0041e000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb7177000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0xb7174000)
	libexpat.so.1 => /lib/libexpat.so.1 (0xb714d000)
	libicudata.so.38 => /usr/lib/libicudata.so.38 (0xb6676000)
	libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb6526000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6520000)
...end sample ldd details ...


Version-Release number of selected component (if applicable):
openoffice.org-draw-2.4.0-12.8.fc9.i386
openoffice.org-impress-2.4.0-12.8.fc9.i386
openoffice.org-graphicfilter-2.4.0-12.8.fc9.i386

How reproducible:
happened once

Steps to Reproduce:
1.open ODG file with OpenOffice.org-Draw and ODP file with OpenOffice.org-Impress
2.copy all in the ODF file and Paste Special this into Impress (second slide in
the presentation) as Draw.8 drawing
3.open the drawing with the embedded editor
4.double click outside of the embedded drawing editor to get out of it
  
Actual results:
crash -- see above

Expected results:
closing embedded editor (special bonus if I would know how to minize bounding
box just to the drawn elements)

Additional info:
Comment 1 Matěj Cepl 2008-05-17 16:33:54 EDT
Created attachment 305818 [details]
Impress presentation
Comment 2 Matěj Cepl 2008-05-17 16:35:12 EDT
Created attachment 305819 [details]
Drawing file
Comment 3 Caolan McNamara 2008-05-18 15:29:55 EDT
Not getting a crash myself, I'll check with valgrind tomorrow. There is a known
"something really weird-ass" with libembedobj at the moment (bug 446005) which
might be related to this.
Comment 4 Caolan McNamara 2008-05-19 15:35:53 EDT
I can't get this to happen for me, maybe I'm not doing it exactly the same way.
Comment 5 Matěj Cepl 2008-05-20 09:33:43 EDT
Haven't happened to me ever since.
Comment 6 Caolan McNamara 2008-05-20 14:18:06 EDT
crapero, its quite possible of course that this is related to our broken gcc
-fno-strict-aliasing which affects another areas in libembed.
Comment 7 Steve Dowe 2008-06-02 06:41:22 EDT
Created attachment 307343 [details]
Stack Trace and ldd of swriter

I get a similar crash in OOo Writer, except I don't need to do anything fancy
with a file.  Just start up writer, type frantically and boom, down she goes. I
have not worked out a means of reproducing it on my system yet.
Comment 8 Caolan McNamara 2008-06-03 05:49:04 EDT
Given then -fasynchronous-unwind-tables is now verified as conflicting most
terribly with -Os I'll try a build with -fasynchronous-unwind-tables filtered out.

(the 2nd stack trace looks like some problem with auto-correct so I believe its
something different)
Comment 9 Caolan McNamara 2008-06-05 05:52:30 EDT
I strongly suspect -fasynchronous-unwind-tables which is now disabled in rawhide
for OOo until the known gcc -fasynchronous-unwind-tables + -Os bug is fixed

Note You need to log in before you can comment on or make changes to this bug.