Bug 447119 - Thunderbird ignores Enigmail per-recipient rules
Thunderbird ignores Enigmail per-recipient rules
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 20:05 EDT by Christopher Tubbs
Modified: 2018-04-11 07:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 18:32:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 434631 None None None Never

  None (edit)
Description Christopher Tubbs 2008-05-17 20:05:21 EDT
Description of problem:
Thunderbird seems to be ignoring OpenGPG enigmail per-recipient rules. Rules
editor also doesn't save rules, or allow rules to be deleted.

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.14-1.fc9.i386
Enigmail version 0.95.6 (20080101)
libgpg-error-1.6-2.i386
gnupg2-2.0.9-1.fc9.i386
pygpgme-0.1-8.fc9.i386
gnupg-1.4.9-1.fc9.i386
gnutls-2.0.4-2.fc9.i386
gpgme-1.1.6-3.fc9.i386

How reproducible:
Every time.

Steps to Reproduce:
1. Run thunderbird with enigmail plugin installed
2. Create per-recipient rule to sign/encrypt/mime always
3. Notice lack of ability to delete rules or save rule changes
  
Actual results:
Rule is permanently in effect.

Expected results:
Rule should be able to be deleted or modified.

Additional info:
Rule CAN be temporarily bypassed per message, if "ignore per-recipient rules" is
checked in compose window before sending.
Comment 1 Matěj Cepl 2008-05-19 18:32:57 EDT
We found that this bug has been already registered in the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=434631) and believe that it is
more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.

We found that this bug has been already registered in the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=§§§) and believe that it is more
appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.