Bug 447124 - yum install tomboy crashes
yum install tomboy crashes
Status: CLOSED DUPLICATE of bug 439635
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 21:11 EDT by Ivan Quirino
Modified: 2014-01-21 18:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 18:24:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Quirino 2008-05-17 21:11:48 EDT
Description of problem:
I've runned "yum install tomboy" and it crashed. This doesn't happens all times,
its imprevisible. This happened before but I don't remeber what package I was
installing. Appears that isn't a problem of downloading specific package.

Version-Release number of selected component (if applicable):
3.2.14

How reproducible:
Using yum to install tomboy or another package.

Steps to Reproduce:
1. yum install tomboy
2. say "Yes" to install
3.
  
Actual results:
it crashed, but is not always

Expected results:
yum should download and install the packages normally

Additional info:
Here is my output:

[root@footman ~]# yum install tomboy
Plugins carregados: fastestmirror, presto, protect-packages, refresh-packagekit
Setting up and reading Presto delta metadata
No Presto metadata available for livna
No Presto metadata available for fedora
No Presto metadata available for adobe-linux-i386
No Presto metadata available for updates
Loading mirror speeds from cached hostfile
 * livna: rpm.livna.org
 * fedora: ftp.man.poznan.pl
 * adobe-linux-i386: linuxdownload.adobe.com
 * updates: ftp.man.poznan.pl
Configurando o Processo de Instalação
Analisando argumentos da instalação de pacotes
Resolvendo Dependências
--> Executando verificação da transação
---> Pacote tomboy.i386 0:0.10.1-2.fc9 definido para ser atualizado
--> Processando Dependência: mono(Mono.Addins) = 0.3.0.0 para o pacote: tomboy
--> Processando Dependência: mono(Mono.Addins.Setup) = 0.3.0.0 para o pacote: tomboy
--> Processando Dependência: mono(gconf-sharp) = 2.16.0.0 para o pacote: tomboy
--> Processando Dependência: mono(Mono.Addins.Gui) = 0.3.0.0 para o pacote: tomboy
--> Processando Dependência: mono(System) = 2.0.0.0 para o pacote: tomboy
--> Processando Dependência: mono(NDesk.DBus) = 1.0.0.0 para o pacote: tomboy
--> Processando Dependência: mono(mscorlib) = 2.0.0.0 para o pacote: tomboy
--> Processando Dependência: mono(gnome-sharp) = 2.16.0.0 para o pacote: tomboy
--> Processando Dependência: mono(gtk-sharp) = 2.10.0.0 para o pacote: tomboy
--> Processando Dependência: mono(NDesk.DBus.GLib) = 1.0.0.0 para o pacote: tomboy
--> Processando Dependência: mono(Mono.Posix) = 2.0.0.0 para o pacote: tomboy
--> Processando Dependência: mono(gdk-sharp) = 2.10.0.0 para o pacote: tomboy
--> Processando Dependência: mono(System.Xml) = 2.0.0.0 para o pacote: tomboy
--> Processando Dependência: mono(gmime-sharp) = 2.2.0.0 para o pacote: tomboy
--> Processando Dependência: mono(glib-sharp) = 2.10.0.0 para o pacote: tomboy
--> Processando Dependência: mono(gconf-sharp-peditors) = 2.16.0.0 para o
pacote: tomboy
--> Processando Dependência: mono(pango-sharp) = 2.10.0.0 para o pacote: tomboy
--> Executando verificação da transação
---> Pacote mono-addins.i386 0:0.3-5.fc9 definido para ser atualizado
---> Pacote ndesk-dbus-glib.i386 0:0.4.1-3.fc9 definido para ser atualizado
---> Pacote gmime-sharp.i386 0:2.2.18-1.fc9 definido para ser atualizado
--> Processando Dependência: gmime = 2.2.18-1.fc9 para o pacote: gmime-sharp
---> Pacote ndesk-dbus.i386 0:0.6.1a-2.fc9 definido para ser atualizado
---> Pacote mono-core.i386 0:1.9.1-2.fc9 definido para ser atualizado
--> Processando Dependência: mono(System.Configuration.Install) = 1.0.5000.0
para o pacote: mono-core
--> Processando Dependência: libgdiplus para o pacote: mono-core
---> Pacote gtk-sharp2.i386 0:2.10.3-2.fc9 definido para ser atualizado
---> Pacote gnome-sharp.i386 0:2.16.1-1.fc9 definido para ser atualizado
--> Executando verificação da transação
---> Pacote gmime.i386 0:2.2.18-1.fc9 definido para ser atualizado
---> Pacote libgdiplus.i386 0:1.9-4.fc9 definido para ser atualizado
---> Pacote mono-extras.i386 0:1.9.1-2.fc9 definido para ser atualizado
--> Processando Dependência: mono(System.Windows.Forms) = 1.0.5000.0 para o
pacote: mono-extras
--> Processando Dependência: mono(System.Windows.Forms) = 2.0.0.0 para o pacote:
mono-extras
--> Executando verificação da transação
---> Pacote mono-winforms.i386 0:1.9.1-2.fc9 definido para ser atualizado
--> Processando Dependência: mono(System.Data) = 1.0.5000.0 para o pacote:
mono-winforms
--> Processando Dependência: mono(System.Web) = 1.0.5000.0 para o pacote:
mono-winforms
--> Processando Dependência: mono(System.Web) = 2.0.0.0 para o pacote: mono-winforms
--> Processando Dependência: mono(System.Data) = 2.0.0.0 para o pacote:
mono-winforms
--> Processando Dependência: libgdiplus-devel para o pacote: mono-winforms
--> Executando verificação da transação
---> Pacote libgdiplus-devel.i386 0:1.9-4.fc9 definido para ser atualizado
---> Pacote mono-data.i386 0:1.9.1-2.fc9 definido para ser atualizado
---> Pacote mono-web.i386 0:1.9.1-2.fc9 definido para ser atualizado
--> Processando Dependência: mono(Mono.Data.Sqlite) = 2.0.0.0 para o pacote:
mono-web
--> Executando verificação da transação
---> Pacote mono-data-sqlite.i386 0:1.9.1-2.fc9 definido para ser atualizado
--> Resolução de Dependências Finalizada

Dependências Resolvidas

=============================================================================
 Pacote                  Arq.       Versão           Repositório       Tamanho
=============================================================================
Instalando:
 tomboy                  i386       0.10.1-2.fc9     fedora            5.7 M
Instalando para as dependências:
 gmime                   i386       2.2.18-1.fc9     fedora            167 k
 gmime-sharp             i386       2.2.18-1.fc9     fedora             46 k
 gnome-sharp             i386       2.16.1-1.fc9     fedora            451 k
 gtk-sharp2              i386       2.10.3-2.fc9     fedora            720 k
 libgdiplus              i386       1.9-4.fc9        fedora            391 k
 libgdiplus-devel        i386       1.9-4.fc9        fedora            7.8 k
 mono-addins             i386       0.3-5.fc9        fedora            262 k
 mono-core               i386       1.9.1-2.fc9      fedora             15 M
 mono-data               i386       1.9.1-2.fc9      fedora            1.8 M
 mono-data-sqlite        i386       1.9.1-2.fc9      fedora            174 k
 mono-extras             i386       1.9.1-2.fc9      fedora            287 k
 mono-web                i386       1.9.1-2.fc9      fedora            3.0 M
 mono-winforms           i386       1.9.1-2.fc9      fedora            3.9 M
 ndesk-dbus              i386       0.6.1a-2.fc9     fedora             59 k
 ndesk-dbus-glib         i386       0.4.1-3.fc9      fedora            9.7 k

Sumário da Transação
=============================================================================
Instalar     16 Pacote(s)         
Atualizar       0 Pacote(s)         
Remover       0 Pacote(s)         

Tamanho total: 32 M
Tamanho total do download: 32 M
Correto? [s/N]:s
Baixando Pacotes:
Downloading DeltaRPMs:
Rebuilding rpms from deltarpms
(1/15): mono-core-1.9.1-2.fc9.i386.rpm                   | 5.0 MB     03:20     
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 354, in doTransaction
    problems = self.downloadPkgs(downloadpkgs) 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1096, in
downloadPkgs
    cache=po.repo.http_caching != 'none',
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 671, in getPackage
    cache=cache
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 649, in _getFile
    http_headers=headers,
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 412, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 398, in
_mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 928, in
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 863, in _retry
    cb_func(obj, *cb_args, **cb_kwargs)
  File "/usr/share/yum-cli/output.py", line 239, in failureReport
    self.logger.error('%s: %s', errobj.url, str(errobj.exception))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe3' in position 21:
ordinal not in range(128)
Comment 1 Ivan Quirino 2008-05-19 11:44:53 EDT
yum crashed again, this time installing wesnoth:

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 354, in doTransaction
    problems = self.downloadPkgs(downloadpkgs) 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1096, in
downloadPkgs
    cache=po.repo.http_caching != 'none',
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 671, in getPackage
    cache=cache
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 649, in _getFile
    http_headers=headers,
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 412, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 398, in
_mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 933, in
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 868, in _retry
    cb_func(obj, *cb_args, **cb_kwargs)
  File "/usr/share/yum-cli/output.py", line 239, in failureReport
    self.logger.error('%s: %s', errobj.url, str(errobj.exception))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe3' in position 21:
ordinal not in range(128)
Comment 2 James Antill 2008-05-19 11:59:23 EDT
 If you can reproduce (it's happening on some mirror error), can you try this:

diff --git a/output.py b/output.py
index 752e18b..494692f 100644
--- a/output.py
+++ b/output.py
@@ -28,7 +28,7 @@ import re # For YumTerm
 
 from urlgrabber.progress import TextMeter
 from urlgrabber.grabber import URLGrabError
-from yum.misc import sortPkgObj, prco_tuple_to_string, to_str, to_unicode_maybe
+from yum.misc import sortPkgObj, prco_tuple_to_string, to_str, to_utf8,
to_unicode_maybe, get_my_lang_code
 from rpmUtils.miscutils import checkSignals
 from yum.constants import *
 
@@ -235,7 +235,9 @@ class YumOutput:
     def failureReport(self, errobj):
         """failure output for failovers from urlgrabber"""
         
-        self.logger.error('%s: %s', errobj.url, str(errobj.exception))
+        self.logger.error('%s: %s',
+                          to_utf8(errobj.url),
+                          to_utf8(str(errobj.exception)))
         self.logger.error(_('Trying other mirror.'))
         raise errobj.exception
     
Comment 3 Ivan Quirino 2008-05-19 17:41:44 EDT
This crashes is only when yum is running from command line, using yumex or
packagekit doesn't cause this.
Comment 4 Seth Vidal 2008-05-30 12:19:18 EDT
Ivan, can you test the patch James posted?
Comment 5 Ivan Quirino 2008-05-30 18:28:27 EDT
No, I can't. I'm not a developer. I'm just a user. Yum recently had an update,
I'll try to install some things to see if it happens again.

Thanks
Comment 6 Ivan Quirino 2008-06-01 18:20:45 EDT
Yum crashed again, after the update, with the same error before.
Comment 7 Thorsten Leemhuis 2008-06-12 07:56:02 EDT
same problem here right now (yum-3.2.16-2.fc9.noarch):

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 354, in doTransaction
    problems = self.downloadPkgs(downloadpkgs) 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1106, in
downloadPkgs
    cache=po.repo.http_caching != 'none',
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 678, in getPackage
    cache=cache
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 656, in _getFile
    http_headers=headers,
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 412, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 398, in
_mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 933, in
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 868, in _retry
    cb_func(obj, *cb_args, **cb_kwargs)
  File "/usr/share/yum-cli/output.py", line 238, in failureReport
    self.logger.error('%s: %s', errobj.url, str(errobj.exception))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 65:
ordinal not in range(128)

patch from james in comment #2 did not help; the last three lines in the
traceback differ slightly

  File "/usr/share/yum-cli/output.py", line 240, in failureReport
    to_utf8(str(errobj.exception)))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 65:
ordinal not in range(128)


workaround I found: use 'LC_ALL=C yum update'
Comment 8 Jan Hutař 2008-08-07 08:47:31 EDT
Hello, are you still able to reproduce with new yum? Current F9 yum version is yum-3.2.17-2.fc9.noarch. Thanks in advance.
Comment 9 James Antill 2008-08-07 18:24:21 EDT

*** This bug has been marked as a duplicate of bug 439635 ***

Note You need to log in before you can comment on or make changes to this bug.