Bug 447158 - link from netcdf-3 breaks upgrades
link from netcdf-3 breaks upgrades
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netcdf (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ed Hill
Fedora Extras Quality Assurance
:
: 448265 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 07:24 EDT by Patrice Dumas
Modified: 2008-09-03 17:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 17:00:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2008-05-18 07:24:08 EDT
Description of problem:

As described in 
https://bugzilla.redhat.com/show_bug.cgi?id=433096
Or what I just filled
https://bugzilla.redhat.com/show_bug.cgi?id=447156

Although I think that this should be fixed in rpm, I think that
this directory could be completely dropped, there is time until 
F-10 and to fix the netcdf packages. But it is up to you.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ed Hill 2008-05-18 08:37:30 EDT
Hi Patrice, thank you for pointing this out.  I had no idea that this RPM 
problem existed.  I was just trying to make life easier for people used to 
having the "/usr/include/netcdf-3" directory.  How annoying!

OK, so I agree that the best fix is to delete /usr/include/netcdf-3 and 
make all the necessary ("-I/usr/include/netcdf") changes to the dependent 
RPMs.  Does anyone have any objections to that?
Comment 2 Orion Poplawski 2008-05-19 11:39:01 EDT
No objections here.
Comment 3 Orion Poplawski 2008-09-03 16:18:08 EDT
*** Bug 448265 has been marked as a duplicate of this bug. ***
Comment 4 Orion Poplawski 2008-09-03 17:00:00 EDT
Removed in rawhide - version 4.0.0-1.

Note You need to log in before you can comment on or make changes to this bug.