Bug 447161 - Quit firefox -> firefox freezes
Quit firefox -> firefox freezes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
: 447547 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 07:41 EDT by sangu
Modified: 2008-06-20 23:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.0-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-20 23:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2008-05-18 07:41:57 EDT
Description of problem:
Quit firefox -> firefox freezes

$ gdb firefox 7034

GNU gdb Fedora (6.8-5.fc10)

[...]
Loaded symbols for /lib/libnss_dns.so.2

sqlite3VdbeExec (p=0xa568a38) at sqlite3.c:43432

43432	  switch( pOp->opcode ){

Missing separate debuginfos, use: debuginfo-install acl.i386 alsa-lib.i386
attr.i386 audiofile.i386 avahi.i386 e2fsprogs.i386 elfutils.i386 esound.i386
gamin.i386 gcc.i386 keyutils.i386 lcms.i386 libICE.i386 libSM.i386
libXScrnSaver.i386 libXau.i386 libXcomposite.i386 libXcursor.i386 libXdmcp.i386
libXext.i386 libXfixes.i386 libXft.i386 libXi.i386 libXinerama.i386
libXrandr.i386 libXrender.i386 libXt.i386 libart_lgpl.i386 libcap.i386
libjpeg.i386 libpng.i386 libselinux.i386 libxml2.i386 nss.i386 openssl.i686
pixman.i386 popt.i386 scim-bridge.i386 startup-notification.i386

(gdb) bt

#0  sqlite3VdbeExec (p=0xa568a38) at sqlite3.c:43432

#1  0x020fffd0 in sqlite3_step (pStmt=0xa568a38) at sqlite3.c:40953

#2  0x021007a9 in sqlite3_exec (db=0x9cde420, 

    zSql=0xc118b48 "DELETE FROM moz_places WHERE id IN (SELECT h.id FROM
moz_places h LEFT OUTER JOIN moz_historyvisits v ON h.id = v.place_id LEFT OUTER
JOIN moz_bookmarks b ON h.id = b.fk WHERE v.id IS NULL AND b.id IS"...,
xCallback=0, 

    pArg=0x0, pzErrMsg=0x0) at sqlite3.c:60015

#3  0x00d6a2a4 in mozStorageConnection::ExecuteSimpleSQL (this=0x998e488, 

    aSQLStatement=@0xbfc63754) at mozStorageConnection.cpp:300

#4  0x00d87351 in nsNavHistoryExpire::ExpireHistoryParanoid (this=0x9ed36b8, 

    aConnection=0x998e488, aMaxRecords=500) at nsNavHistoryExpire.cpp:860

#5  0x00d88e5b in nsNavHistoryExpire::OnQuit (this=0x9ed36b8)

    at nsNavHistoryExpire.cpp:221

#6  0x00d82c12 in nsNavHistory::Observe (this=0x9ed35f0, aSubject=0x0, 

    aTopic=0x1061601 "quit-application", aData=0x1061612)

    at nsNavHistory.cpp:4714

#7  0x00e6fbbd in nsObserverList::NotifyObservers (this=0x9ee31f0, 

    aSubject=0x0, aTopic=0x1061601 "quit-application", someData=0x1061612)

    at nsObserverList.cpp:128

#8  0x00e6ff2e in nsObserverService::NotifyObservers (this=0x9a655b8, 

    aSubject=0x0, aTopic=0x1061601 "quit-application", someData=0x1061612)

    at nsObserverService.cpp:181

#9  0x00c8fd91 in nsAppStartup::Quit (this=0x9d7f3f8, aMode=1)

---Type <return> to continue, or q <return> to quit---

    at nsAppStartup.cpp:311

#10 0x00c8f850 in nsAppStartup::ExitLastWindowClosingSurvivalArea (this=0x1)

    at nsAppStartup.cpp:406

#11 0x00c8fc7f in nsAppStartup::Observe (this=0x9d7f3f8, aSubject=0x0, 

    aTopic=0x1060a49 "xul-window-destroyed", aData=0x0) at nsAppStartup.cpp:499

#12 0x00e6fbbd in nsObserverList::NotifyObservers (this=0x9ee2d04, 

    aSubject=0x0, aTopic=0x1060a49 "xul-window-destroyed", someData=0x0)

    at nsObserverList.cpp:128

#13 0x00e6ff2e in nsObserverService::NotifyObservers (this=0x9a655b8, 

    aSubject=0x0, aTopic=0x1060a49 "xul-window-destroyed", someData=0x0)

    at nsObserverService.cpp:181

#14 0x00c7b419 in nsXULWindow::Destroy (this=0xa249d40) at nsXULWindow.cpp:548

#15 0x00c7e2e5 in nsWebShellWindow::Destroy (this=0xa249d40)

    at nsWebShellWindow.cpp:873

#16 0x00c72be8 in nsChromeTreeOwner::Destroy (this=0xa1b65f0)

    at nsChromeTreeOwner.cpp:383

#17 0x00a8da41 in nsGlobalWindow::ReallyCloseWindow (this=0xa1b6ea8)

    at nsGlobalWindow.cpp:5613

#18 0x00a92c63 in nsCloseEvent::Run (this=0xc1137e8) at nsGlobalWindow.cpp:5422

#19 0x00e987ca in nsThread::ProcessNextEvent (this=0x992fe40, mayWait=1, 

    result=0xbfc63b94) at nsThread.cpp:510

#20 0x00e6576c in NS_ProcessNextEvent_P (thread=0x323, mayWait=1)

    at nsThreadUtils.cpp:227

---Type <return> to continue, or q <return> to quit---

#21 0x00ddb014 in nsBaseAppShell::Run (this=0x9cfc620)

    at nsBaseAppShell.cpp:170

#22 0x00c8f7fc in nsAppStartup::Run (this=0x9d7f3f8) at nsAppStartup.cpp:181

#23 0x0065fe91 in XRE_main (argc=1, argv=0xbfc672a4, aAppData=0x98e3958)

    at nsAppRunner.cpp:3170

#24 0x08049169 in main (argc=1, argv=0xbfc672a4) at nsXULStub.cpp:364

Current language:  auto; currently c


Version-Release number of selected component (if applicable):
3.0-0.63.cvs20080516.fc10

How reproducible:
always

Steps to Reproduce:
1. launch firefox
2. open a web site
3. quit 
  
Actual results:


Expected results:


Additional info:
sqlite-3.5.8-1.fc10
Comment 1 Pierre Ossman 2008-05-20 12:05:08 EDT
*** Bug 447547 has been marked as a duplicate of this bug. ***
Comment 2 sangu 2008-06-20 23:00:45 EDT
Fixed in firefox-3.0-1.fc10 and xulrunner-1.9-1.fc10.

Note You need to log in before you can comment on or make changes to this bug.