Bug 447175 - TB8a97ef57 NCHardwareList.py:692:load:ValueError: invalid literal for int() with base 10: 'None'
TB8a97ef57 NCHardwareList.py:692:load:ValueError: invalid literal for int() w...
Status: CLOSED DUPLICATE of bug 426766
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 11:00 EDT by Correct
Modified: 2008-05-19 04:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 04:34:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Correct 2008-05-18 11:00:24 EDT
Component: system-config-network


Version: 1.4.3

Summary: TB8a97ef57 NCHardwareList.py:692:load:ValueError: invalid literal for
int() with base 10: 'None'


Traceback (most recent call last):

  File "/usr/sbin/system-config-network-gui", line 166, in runit

    window = mainDialog()

  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
253, in __init__

    self.load()

  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
277, in load

    self.loadHardware()

  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
289, in loadHardware

    hardwarelist = getHardwareList()

  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
780, in getHardwareList

    __HWList.load()

  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
692, in load

    hw.Modem.BaudRate = int(wvdial[dev]['Baud'])

ValueError: invalid literal for int() with base 10: 'None'



Local variables in innermost frame:

hwconf: <netconfpkg.NCHardwareList.ConfHWConf instance at 0x930a74c>

i: 2

self: HardwareList.Ethernet.eth0.Status=ok

HardwareList.Ethernet.eth0.Name=eth0

HardwareList.Ethernet.eth0.Type=Ethernet

HardwareList.Ethernet.eth0.Card.ModuleName=dmfe

HardwareList.Ethernet.eth0.Description=Davicom Semiconductor, Inc. 21x4x
DEC-Tulip compatible 10/100 Ethernet

HardwareList.Ethernet.eth1.Status=ok

HardwareList.Ethernet.eth1.Name=eth1

HardwareList.Ethernet.eth1.Type=Ethernet

HardwareList.Ethernet.eth1.Card.ModuleName=ne2k-pci

HardwareList.Ethernet.eth1.Description=Realtek Semiconductor Co., Ltd. RTL-8029(AS)

HardwareList.Modem.Modem0.Status=настроено

HardwareList.Modem.Modem0.Name=Modem0

HardwareList.Modem.Modem0.Modem.DeviceName=/dev/modem

HardwareList.Modem.Modem0.Type=Modem

HardwareList.Modem.Modem0.Description=Generic Modem


isdncard: <netconfpkg.NCisdnhardware.ConfISDN instance at 0x954c42c>

hw: Hardware.Status=настроено

Hardware.Name=Modem0

Hardware.Modem.DeviceName=/dev/modem

Hardware.Type=Modem

Hardware.Description=Generic Modem


dev: Modem0

wvdial: <netconfpkg.conf.ConfSMB.ConfSMB instance at 0x954c60c>
Comment 1 Harald Hoyer 2008-05-19 04:34:42 EDT

*** This bug has been marked as a duplicate of 426766 ***
Comment 2 Harald Hoyer 2008-05-19 04:36:18 EDT

system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 stable
repository.  If problems still persist, please make note of it in this bug report.



update your system-config-network

Note You need to log in before you can comment on or make changes to this bug.