Bug 447197 - Konsole crashes at startup after having gone into an infinite loop
Konsole crashes at startup after having gone into an infinite loop
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
9
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 14:56 EDT by Torsten Ekedahl
Modified: 2008-05-20 17:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 17:24:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 162380 None None None Never

  None (edit)
Description Torsten Ekedahl 2008-05-18 14:56:30 EDT
Description of problem:
konsole crashes on start up

Version-Release number of selected component (if applicable):
4.0.3-9.fc9

How reproducible:
Totally at my current configuration (it didn't happen at first but now it 
happens every time).

Steps to Reproduce:
1. Run konsole
2.
3.
  
Actual results:
konsole crashes after having grown to about 200Mb


Expected results:
konsole starts running

Additional info:

Running under gdb shows that it crashes at
0x07ac9cdc in _int_malloc (av=<value optimized out>, bytes=<value optimized
out>) at malloc.c:4085

Giving a backtrace is not possible as there seems to be some (almost) infinite
recursion happening. 

Going up a few steps gives this:

#1  0x07acadc6 in malloc_check (sz=<value optimized out>, caller=Could not find
the frame base for "mallo
c_check".
) at hooks.c:265
265       victim = (top_check() >= 0) ? _int_malloc(&main_arena, sz+1) : NULL;
(gdb) 
#2  0x07acbbf5 in __libc_malloc (bytes=<value optimized out>) at malloc.c:3546
3546        return (*hook)(bytes, RETURN_ADDRESS (0));
(gdb) 
#3  0x005bbd9d in qMalloc (size=Could not find the frame base for
"qMalloc(unsigned int)".
) at global/qglobal.cpp:1971
1971    void *qMalloc(size_t size) { return ::malloc(size); }
Current language:  auto; currently c++
(gdb) 
#4  0x005f54e7 in QString (this=<value optimized out>, unicode=<value optimized
out>, 
    size=<value optimized out>) at tools/qstring.cpp:795
795             d = (Data*) qMalloc(sizeof(Data)+size*sizeof(QChar));
(gdb) 
#5  0x005f58af in QString::mid (this=<value optimized out>, position=<value
optimized out>, 
    n=<value optimized out>) at tools/qstring.cpp:2854
2854        return QString((const QChar*) d->data + position, n);
(gdb) 
#6  0x0064ee3a in QFSFileEngine::fileName (this=<value optimized out>,
file=<value optimized out>)
    at io/qfsfileengine_unix.cpp:660
660                 return d->filePath.mid(slash + 1);
(gdb) 
#7  0x0064e9f8 in QFSFileEngine::fileFlags (this=<value optimized out>,
type=<value optimized out>)
    at io/qfsfileengine_unix.cpp:630
630             if (fileName(BaseName)[0] == QLatin1Char('.')
(gdb) up 10
#17 0x00304320 in Konsole::SessionManager::loadProfile (this=<value optimized out>, 
    shortPath=<value optimized out>)
    at /usr/src/debug/kdebase-4.0.3/apps/konsole/src/SessionManager.cpp:140
140         bool result = reader->readProfile(path,newProfile,parentProfile);

Further attempts to go up leads to the same position:

(gdb) up 10
#27 0x00304346 in Konsole::SessionManager::loadProfile (this=<value optimized out>, 
    shortPath=<value optimized out>)
    at /usr/src/debug/kdebase-4.0.3/apps/konsole/src/SessionManager.cpp:146
146             QString parentKey = loadProfile(parentProfile);
(gdb) up
#28 0x00304346 in Konsole::SessionManager::loadProfile (this=<value optimized out>, 
    shortPath=<value optimized out>)
    at /usr/src/debug/kdebase-4.0.3/apps/konsole/src/SessionManager.cpp:146
146             QString parentKey = loadProfile(parentProfile);
(gdb) 
#29 0x00304346 in Konsole::SessionManager::loadProfile (this=<value optimized out>, 
    shortPath=<value optimized out>)
    at /usr/src/debug/kdebase-4.0.3/apps/konsole/src/SessionManager.cpp:146
146             QString parentKey = loadProfile(parentProfile);
Comment 1 Steven M. Parrish 2008-05-20 09:24:39 EDT
Checked upstream could not find a matching bug report.  Please file upstream at
http://bugs.kde.org  Once filed please update this report with upstream info. 
We will monitor upstream report.
Comment 2 Torsten Ekedahl 2008-05-20 17:03:07 EDT
This is now Bug 162380 at bugs.kde.org

Note You need to log in before you can comment on or make changes to this bug.