Bug 447198 - Monitor mode on a 4965AGN card
Monitor mode on a 4965AGN card
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 15:06 EDT by analyzer
Modified: 2008-06-12 13:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6.25.4-14.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 13:55:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description analyzer 2008-05-18 15:06:23 EDT
Description of problem:
Monitor mode on a 4965AGN card doesnt work (IWLWIFI).

Additional info:
Problem has been reported on
http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1537

Patch exists and tested by myself (and others) on 4965 chipset:
http://www.intellinuxwireless.org/bugzilla/attachment.cgi?id=1377

NB: Presence of multiple messages in /var/log/messages => "iwl4965: byte count
out of range [16.4K] : 10" due to the driver
filtering-out 802.11 ACK packets, which are only 10 bytes long (this is less
important than having monitor mode)
Comment 1 analyzer 2008-05-28 17:07:30 EDT
precision: this bug is obviously also in fedora 8
Comment 2 John W. Linville 2008-05-30 14:12:56 EDT
I have yet to see this patch upstream.  Care to prod the Intel folks into
posting it?
Comment 3 John W. Linville 2008-05-30 14:20:17 EDT
Ah, but it looks like a version of this one has been posted:

   http://www.intellinuxwireless.org/bugzilla/attachment.cgi?id=1381

As this:

commit 4419e39b6041b213e49bb13fd40fb267de0eb568
Author: Abhijeet Kolekar <abhijeet.kolekar@intel.com>
Date:   Mon May 5 10:22:47 2008 +0800

    iwlwifi : Set monitor mode for 4965

    The patch leverages mac80211 configure_filter to enable iwl4965
    monitor mode.

    Signed-off-by: Abhijeet Kolekar <abhijeet.kolekar@intel.com>
    Signed-off-by: John W. Linville <linville@tuxdriver.com>

This should be included in the kernels here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=50951

Do those kernels resolve the issue for you?
Comment 4 analyzer 2008-05-30 20:23:51 EDT
The patch you mention only applys to iwl3945 (id=1381).

Can you check if the monitor mode has been included in this version for chipset
4965 (id=1377) => just need to check if iwl4965-base.c / iwl-4965.c are modified
according to the patch I reported (I saw the linux-2.6-wireless-pending.patch,
and it seems ok)

Apparently, these kernels are still not available for F8, am I right ?

Any info of when they will be in stable repos ? (Im stuck with a home made
kernel at this time)
Comment 5 John W. Linville 2008-06-02 07:43:42 EDT
There are both 3945 and 4965 versions of the patch in question.  Please note the
"4965" in the commit I referenced. :-)

The equivalent F8 kernels are available here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=50974

They are not yet available in the normal yum updates repository.  Could you give
them a try from Koji?
Comment 6 analyzer 2008-06-02 14:37:22 EDT
Ok, i'll test the kernel as soon as kmod-nvidia / xorg-x11-drv-nvidia /
xorg-x11-drv-nvidia-libs are available ;)

I'll keep you informed, tx for infos/help
Comment 7 analyzer 2008-06-03 16:48:01 EDT
I can confirm that this bug for monitor mode is fixed by this kernel.

No info at the moment about 802.11 ACK packets (10 bytes long) which were dumped
in /var/log/messages => It may be correct to.

Tx John.
Comment 8 analyzer 2008-06-03 17:23:35 EDT
I perhaps answered too quickly, because even if the monitor mode worked, I tried
two times to connect to my WiFi network, and I got a system freeze ... (kernel
panic?)
Comment 9 analyzer 2008-06-03 18:17:21 EDT
I switched back to my old kernel and I got no troubles (except the ACK packets,
which is less important).

Kernel in question is: kernel-2.6.25-0.121.rc5.git4 + 4965 monitor patch (id=1377).

Im trying to figure if there are valuable informations in the /var/log/messages

NB: I can give you kernel-2.6.25-0.121.rc5.git4.fc8.src.rpm I use if it can help
(I even kept my rpmbuild env for this kernel)
Comment 10 John W. Linville 2008-06-12 13:55:07 EDT
I'm closing this on the basis of comment 7.  If you continue to have the 
problems discussed in comment 8 then please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.