Bug 447237 - Default configuration of idmapd does not work in many cases
Default configuration of idmapd does not work in many cases
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils-lib (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 20:33 EDT by W. Michael Petullo
Modified: 2008-07-03 23:41 EDT (History)
0 users

See Also:
Fixed In Version: 1.1.1-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 23:41:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2008-05-18 20:33:49 EDT
Description of problem:
The nfs-utils-lib package installs /etc/idmapd.conf. The default configuration contains the line 
"Domain = localhost.localdomain." This line is often incompatible with the way NFS is configured. 

Version-Release number of selected component (if applicable):
nfs-utils-lib-1.1.1-3.fc9.ppc

How reproducible:
Every time

Steps to Reproduce:
1. Install nfs-utils-lib and nfs-utils. Start idmapd.
2. Mount an NFS share.
3. Perform an "ls -l" of a directory within the mounted share.
  
Actual results:
The owner and group owners of files may be set to "nobody." This is because the NFS domain is not set 
to "localhost.localdomain" and does not match the domain setting in idmapd.conf. Idmapd must be 
manually configured.

Expected results:
The owner of the files should be listed properly.

Additional info:
Removing the "Domain =" entry seems to force idmapd to determine the NFS domain by using the 
computer's hostname. This seems to be the default behavior of the NFS server as well. Therefore, I 
recommend removing the "Domain =" entry from the idmapd.conf file that nfs-utils-lib installs.
Comment 1 Steve Dickson 2008-06-04 10:56:53 EDT
If you actually define you local domain to something other
than "localhost.localdomain", are the uid/gid mapped correctly?
Comment 2 W. Michael Petullo 2008-06-04 23:51:36 EDT
Yes. My client and server are configured as imp.flyn.org and golem.flyn.org (This is what hostname 
prints). The UID and GID's are mapped correctly with *no* "Domain =" entry in idmapd.conf.
Comment 3 Steve Dickson 2008-06-27 13:07:24 EDT
Fixed in nfs-utils-lib-1.1.1-4.fc9
Comment 4 Fedora Update System 2008-06-27 13:12:00 EDT
nfs-utils-lib-1.1.1-4.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-06-28 18:17:14 EDT
nfs-utils-lib-1.1.1-4.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nfs-utils-lib'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5824
Comment 6 Fedora Update System 2008-07-03 23:41:12 EDT
nfs-utils-lib-1.1.1-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.