Bug 447270 - Pakistan introducing DST
Pakistan introducing DST
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tzdata (Show other bugs)
5.1
All Linux
high Severity high
: rc
: ---
Assigned To: Petr Machata
: ZStream
Depends On:
Blocks: 391501 447294 447295 447296 448672 449349
  Show dependency treegraph
 
Reported: 2008-05-19 04:16 EDT by Daniel McNamara
Modified: 2015-05-04 21:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2008-0506
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 05:27:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A fix... I guess (687 bytes, patch)
2008-05-19 07:24 EDT, Petr Machata
no flags Details | Diff

  None (edit)
Description Daniel McNamara 2008-05-19 04:16:37 EDT
Description of problem:

As on June 1 2008 Pakistan will be introducing DST moving clocks ahead one hour.

Ref http://www.worldtimezone.com/dst_news/dst_news_pakistan01.html

Version-Release number of selected component (if applicable):


How reproducible:

Everytime. 

Steps to Reproduce:
1. zdump -v /usr/share/zoneinfo/Asia/Karachi | grep 2008
2. No DST definitions
3. Sigh at Yet Another Country Changing DST With Short Notice (YACCDSTWSN)
  
Actual results:

Lack of DST for Pakistan in 2008

Expected results:

DST for Pakistan 2008

Additional info:

This does of course apply to all versions of RHEL. New DST does not even appear
to be in upstream tzdata set yet. I expect this will be fixed very shortly.
Comment 1 Petr Machata 2008-05-19 07:24:22 EDT
Created attachment 305928 [details]
A fix... I guess

The closest thing to official announcement that I found just mentions that the
change will be introduced on Jun/1, and will last three months, which is not
very exact.  timeanddate.com think that DST will start 0:01 (local time) and
end Aug/31 0:01.  This is reasonable, because that matches transition points
from previous DST period (both Sundays, 0:01).
Comment 10 errata-xmlrpc 2008-05-28 05:27:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0506.html

Note You need to log in before you can comment on or make changes to this bug.