Bug 447288 - Infinite loop booting F9 kernel in F8 dom0.
Infinite loop booting F9 kernel in F8 dom0.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel-xen-2.6 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 06:52 EDT by Jan ONDREJ
Modified: 2008-05-19 10:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 10:56:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2008-05-19 06:52:02 EDT
Description of problem:
After installing and booting Fedora 9 kernel on Fedora 8 kernel goes to infinite
loop. These are latest messages on my virtual console:

XENBUS: Device with no driver: device/vbd/51712
XENBUS: Device with no driver: device/vif/0
XENBUS: Device with no driver: device/console/0
  Magic number: 1:252:3141
Freeing unused kernel memory: 300k freed
Write protecting the kernel read-only data: 1076k
USB Universal Host Controller Interface driver v3.0
blkfront: xvda: barriers enabled
 xvda: xvda1
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
SELinux: policy loaded with handle_unknown=allow
type=1403 audit(1211190374.979:2): policy loaded auid=4294967295 ses=4294967295


Version-Release number of selected component (if applicable):
Linux version 2.6.25-2.fc9.x86_64.xen (mockbuild@) (gcc version 4.3.0 20080416
(Red Hat 4.3.0-7) (GCC) ) #1 Fri Apr 25 13:13:13 EDT 2008
But same for updated and same for non-updated F9.

How reproducible:
always

Steps to Reproduce:
1. install domU F9
  
Actual results:
infinite loop

Expected results:
login:

Additional info:
Same problem for x86_64 and i386 kernels. Disabling selinux (selinux=0) does not
help, message is changed, but still does not boot more.
Comment 1 Mark McLoughlin 2008-05-19 08:30:58 EDT
Okay, questions:

  - This is a x86_64 F-8 Dom0? What versions of kernel-xen and xen?

  - The output you pasted is from "virsh console <F9DomU>" ?

  - Try putting "console=hvc debug" in the guest's kernel command line

  - How do you know this is an "infinite loop"?

  - Any HV error messages on the Dom0 console or interesting messages in 
    /var/log/xen?
Comment 2 Jan ONDREJ 2008-05-19 09:21:58 EDT
(In reply to comment #1)
> Okay, questions:
> 
>   - This is a x86_64 F-8 Dom0? What versions of kernel-xen and xen?

Now an updated F8 on dom0:
xen-3.1.2-2.fc8
kernel-xen-2.6.21.7-3.fc8

>   - The output you pasted is from "virsh console <F9DomU>" ?

Output is pasted from virt-install after rebooted to installed system.
 
>   - Try putting "console=hvc debug" in the guest's kernel command line

console=hvc helps. May be it is a problem of virt-install or another program
which updating grub.conf, that there was console=xvc0.

>   - How do you know this is an "infinite loop"?

I am not sure.

Thank you for help.
Can you change this bug to proper component, which is responsible for console=xvc0?
Comment 3 Mark McLoughlin 2008-05-19 10:31:51 EDT
(In reply to comment #2)
> (In reply to comment #1)
>  
> >   - Try putting "console=hvc debug" in the guest's kernel command line
> 
> console=hvc helps. 

So, it was booting find before, you just weren't getting console output?

> May be it is a problem of virt-install or another program
> which updating grub.conf, that there was console=xvc0.

What is the exact virt-install command line you used?

I assume you had --nographics?

I've tried to reproduce this and failed - with --nographics, anaconda put
"console=hvc0" in my grub.conf

Are you sure you didn't also have -x "console=xvc0"?

AFAICS, anaconda would put "console=xvc0" in the grub command line only if:

  a) /dev/xvc0 worked, which it won't with the F-9 kernel-xen

  b) console=xvc0 was passed via the kernel command line to anaconda
Comment 4 Jan ONDREJ 2008-05-19 10:56:01 EDT
> > May be it is a problem of virt-install or another program
> > which updating grub.conf, that there was console=xvc0.
> 
> What is the exact virt-install command line you used?

I am using my kickstart file, because there is still no minimal Fedora install
via anaconda.

> I assume you had --nographics?

Yes.

> I've tried to reproduce this and failed - with --nographics, anaconda put
> "console=hvc0" in my grub.conf
> 
> Are you sure you didn't also have -x "console=xvc0"?

--append="console=xvc0" was a part of my old kickstart file.

> AFAICS, anaconda would put "console=xvc0" in the grub command line only if:
> 
>   a) /dev/xvc0 worked, which it won't with the F-9 kernel-xen
> 
>   b) console=xvc0 was passed via the kernel command line to anaconda

After removal of this parameter from append F9 installation works well.

I think you should close this bug.

Note You need to log in before you can comment on or make changes to this bug.