Bug 447364 - firefox starts in offline mode after reboot
firefox starts in offline mode after reboot
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 13:31 EDT by Randy Zagar
Modified: 2018-04-11 04:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 08:14:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 424626 None None None Never

  None (edit)
Description Randy Zagar 2008-05-19 13:31:19 EDT
Description of problem:
Firefox unable to browse web because "work offline" is checked.

Version-Release number of selected component (if applicable):
fedora 9 3.0-0.60

How reproducible:
always after a fresh boot

Steps to Reproduce:
1. boot system
2. login
3. open firefox
  
Actual results:
unable to open web pages due to "working offline"

Expected results:
open web pages normally?

Additional info:
This could be related to general Network Manager weirdness with respect to wired
networks.
Comment 1 LH 2008-06-01 16:40:22 EDT
I have this same problem. Firefox always defaults to offline mode. This could be
due to network manager thinking I'm offline as I use a static IP for wired
connection and NM doesn't understand this.
Comment 2 Nicola Soranzo 2008-06-02 05:22:48 EDT
(In reply to comment #1)
> I have this same problem. Firefox always defaults to offline mode. This could be
> due to network manager thinking I'm offline as I use a static IP for wired
> connection and NM doesn't understand this.

Yes, this is the diagnosis. Take a look at the upstream bug linked in this bug
report for more info.
Comment 3 Matěj Cepl 2008-06-02 08:14:37 EDT
Two things:
a) for the workaround, follow the advice of Dan Williams at
https://bugzilla.mozilla.org/show_bug.cgi?id=424626#c39
b) this is not firefox, but Network Manager bug -- firefox just does here what
it is supposed to do, IMHO.
c) I think it should be CLOSED/UPSTREAM, as it is being resolved upstream, and
possible fix will come to use as well.

If you disagree, please, reopen, but against NetworkManager.

Note You need to log in before you can comment on or make changes to this bug.