Bug 447378 - fence_apc unable to connect via ssh to APC 7900 Switched Rack PDU
fence_apc unable to connect via ssh to APC 7900 Switched Rack PDU
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 14:31 EDT by Dean Jansa
Modified: 2009-05-18 17:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 17:16:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Jansa 2008-05-19 14:31:58 EDT
Description of problem:

I am unable to use fence_apc -x to connect to our ssh enabled apc; cmdline ssh
is able to connect:

[root@link-13 fence]# ssh apc@marathon-apc
Authenticated with partial success.
apc@marathon-apc's password:



American Power Conversion               Network Management Card AOS      v2.6.4
(c) Copyright 2004 All Rights Reserved  Rack PDU APP                     v2.6.5
-------------------------------------------------------------------------------
Name      : marathon-apc                              Date : 05/19/2008
Contact   : Unknown                                   Time : 10:59:44
Location  : MSP Lab                                   User : Administrator
Up Time   : 0 Days 0 Hours 2 Minutes                  Stat : P+ N+ A+

Switched Rack PDU: Communication Established

------- Control Console -------------------------------------------------------

     1- Device Manager
     2- Network
     3- System
     4- Logout

===========================================================================


[root@link-13 fence]# fence_apc -x  -o status -a marathon-apc -l apc -p apc -n 3 -v
Unable to connect/login to fencing device




Version-Release number of selected component (if applicable):

fence-1.32.57-1
Comment 1 RHEL Product and Program Management 2008-05-19 14:41:00 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Marek Grac 2008-05-21 11:34:59 EDT
Fixed, ssh protocol and cipher has to be specified otherwise it is too slow.
Comment 5 Dean Jansa 2008-05-27 14:27:02 EDT
Am I doing something wrong?  I still can not connect.

ssh from cmdline to marathon-apc works, fence_apc still does not:

[root@link-13 rhn]# ssh apc@marathon-apc
Authenticated with partial success.
apc@marathon-apc's password: 



American Power Conversion               Network Management Card AOS      v2.6.4
(c) Copyright 2004 All Rights Reserved  Rack PDU APP                     v2.6.5
-------------------------------------------------------------------------------
Name      : marathon-apc                              Date : 05/27/2008
Contact   : Unknown                                   Time : 12:25:21
Location  : MSP Lab                                   User : Administrator
Up Time   : 6 Days 3 Hours 34 Minutes                 Stat : P+ N+ A+     

Switched Rack PDU: Communication Established
                                            
------- Control Console -------------------------------------------------------

     1- Device Manager
     2- Network
     3- System
     4- Logout

     <ESC>- Main Menu, <ENTER>- Refresh, <CTRL-L>- Event Log
> 4Connection to marathon-apc closed by remote host.


==========================


[root@link-13 rhn]# fence_apc -x -o status -a marathon-apc -l apc -p apc -n 1 -v
 
Unable to connect/login to fencing device
[root@link-13 rhn]# 

[root@link-13 rhn]# rpm -q fence
fence-1.32.58-1
Comment 6 Marek Grac 2008-06-02 10:32:59 EDT
Works for me:

for i in `seq 1 50`; do time ./fence_apc.py -a marathon-apc -l apc -p apc -n 1
-o status -x; done

Real time for each run was between 6.439 and 6.597 seconds [brno - msp]
Comment 7 Dean Jansa 2008-06-02 12:39:56 EDT
Doesn't work for me the first time --  second time it runs.

This is easy to reproduce -- remove the from ~/.ssh/known_hosts for marathon-apc
and run.

[root@link-13 ~]# fence_apc -a marathon-apc -l apc -p apc -o status -n 1 -x
Unable to connect/login to fencing device

[root@link-13 ~]# fence_apc -a marathon-apc -l apc -p apc -o status -n 1 -x
Status: ON

[root@link-13 ~]# rpm -q fence
fence-1.32.60-1




Comment 8 Marek Grac 2008-06-04 10:27:37 EDT
Fixed in STABLE2/master (timeout after accepting host key is increased from
SHELL_TIMEOUT to LOGIN_timeout)
Comment 9 Fedora Update System 2008-06-11 03:56:02 EDT
rgmanager-2.03.04-1.fc9,gfs2-utils-2.03.04-1.fc9,cman-2.03.04-1.fc9 has been submitted as an update for Fedora 9
Comment 11 Fedora Update System 2008-06-11 19:34:44 EDT
rgmanager-2.03.04-1.fc9, gfs2-utils-2.03.04-1.fc9, cman-2.03.04-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rgmanager gfs2-utils cman'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5243
Comment 12 Fedora Update System 2008-06-12 22:25:28 EDT
rgmanager-2.03.04-1.fc9, gfs2-utils-2.03.04-1.fc9, cman-2.03.04-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 errata-xmlrpc 2009-05-18 17:16:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1050.html

Note You need to log in before you can comment on or make changes to this bug.