Bug 447424 - irc account doesn't work properly after first use
irc account doesn't work properly after first use
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 17:14 EDT by Pedro Silva
Modified: 2008-05-19 21:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 21:17:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Silva 2008-05-19 17:14:51 EDT
Description of problem:

First time I run empathy, everything worked. I could add accounts, connect to
them and talk. I added a Gtalk, MSN and irc accounts.

The following day, when I run empathy, the irc account starts to misbehave.
My irc account know my nickserv's password for auto identify and when empathy
connects, I get a message saying the password was accepted and then a windows
shows up saying:

A programming error has been detected:

Traceback (most recent call last):
  File
"/usr/lib/python2.5/site-packages/cohoba/technobabble/ui/ConversationWindow.py",
line 125, in on_window_destroy
    self.conversation.close()
  File
"/usr/lib/python2.5/site-packages/cohoba/common/TelepathyConversation.py", line
93, in close
    self.textchannel_iface[CHANNEL_INTERFACE].Close(reply_callback=lambda: None,
error_callback=global_error_handler)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
TypeError: call_blocking() got an unexpected keyword argument 'reply_callback'

If I try to join a channel in irc, the same error shows up and I can't use the
irc account.


Version-Release number of selected component (if applicable):

Using empathy-libs-0.22.1-1.fc9.i386 and empathy-0.22.1-1.fc9.i386.

How reproducible:

Add accounts first time you run empathy (irc). Work. Sleep. Wake. Login. Try to
use the irc account.

 
Actual results:

Irc account not usable.

Expected results:

Irc account works just has it did the first time.

Additional info:

Great app! :)
Comment 1 Brian Pepple 2008-05-19 19:59:31 EDT
I'm unable to reproduce this in 0.23.1 (which is in Test Updates repo).  Could
you update to that, and see if you still see this?  Thanks.
Comment 2 Brian Pepple 2008-05-19 20:03:32 EDT
(In reply to comment #0)
> Traceback (most recent call last):
>   File
> "/usr/lib/python2.5/site-packages/cohoba/technobabble/ui/ConversationWindow.py",
> line 125, in on_window_destroy
>     self.conversation.close()
>   File
> "/usr/lib/python2.5/site-packages/cohoba/common/TelepathyConversation.py", line
> 93, in close
>     self.textchannel_iface[CHANNEL_INTERFACE].Close(reply_callback=lambda: None,
> error_callback=global_error_handler)
>   File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
>     **keywords)
> TypeError: call_blocking() got an unexpected keyword argument 'reply_callback'

BTW, are you running Cohoba at the same time as Empathy?  This could be the
source of your problem, based on your traceback.
Comment 3 Pedro Silva 2008-05-19 21:17:57 EDT
Thanks for your quick reply. Indeed I installed cohoba while searching for
telepathy plugins. Once I removed cohoba, everything was back to normal. I can
use the irc account again.

Note You need to log in before you can comment on or make changes to this bug.