Bug 447447 - missed BuildRequires in ekiga.src.rpm
missed BuildRequires in ekiga.src.rpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ekiga (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 18:47 EDT by Alexey Lubimov
Modified: 2008-05-20 07:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 04:21:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from rpmbuild (8.57 KB, text/plain)
2008-05-19 18:47 EDT, Alexey Lubimov
no flags Details
log from configure script (42.63 KB, text/plain)
2008-05-19 18:48 EDT, Alexey Lubimov
no flags Details

  None (edit)
Description Alexey Lubimov 2008-05-19 18:47:44 EDT
Description of problem:

rpmbuild --rebuild ekiga*.src.rpm failed  


Version-Release number of selected component (if applicable):

ekiga-2.0.11-3.fc9.src.rpm 


How reproducible:

try rebuild ekiga.src.rpm in clean build environment

build process fail this message:

configure: error: You need the PWLib library to compile Ekiga 
error: Bad exit status from /var/tmp/rpm-tmp.46573 (%build) 
    Bad exit status from /var/tmp/rpm-tmp.46573 (%build) 

But real problem  from config.log:

./configure: line 22411: g++: command not found


See attachmets - log.txt from rpmbuild and config.log from ./configure script. 

Conclusion:

ekiga requires package gcc-c++, but it is BuildRequires not defined in spec
Comment 1 Alexey Lubimov 2008-05-19 18:47:44 EDT
Created attachment 306028 [details]
log from rpmbuild
Comment 2 Alexey Lubimov 2008-05-19 18:48:31 EDT
Created attachment 306029 [details]
log from configure script
Comment 3 Daniel Veillard 2008-05-20 04:21:07 EDT
http://fedoraproject.org/wiki/Packaging/Guidelines#head-4cadce5e79d38a63cad3941de1dadc9d25d67d30-2

-----------------
There is no need to include the following packages or their dependencies as
BuildRequires because they would occur too often
....
gcc-c++
....
-----------------

I not too happy to add such a BuildRequires, there is a limit, really,
and this conflicts with the published docs!
For pwlib, the requirement is there

BuildRequires: pwlib-devel >= 1.10.10

as presented don't see a bug in the spec file,

Daniel
Comment 4 Alexey Lubimov 2008-05-20 07:12:34 EDT
http://fedoraproject.org/wiki/Packaging/Guidelines#head-4cadce5e79d38a63cad3941de1dadc9d25d67d30-2

Maybe, add with list as Requires: to package rpmbuild?



Note You need to log in before you can comment on or make changes to this bug.