Bug 447451 - firefox-3 fails to print when X server depth is 16 bits
firefox-3 fails to print when X server depth is 16 bits
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Martin Stransky
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 19:02 EDT by Martin Stransky
Modified: 2008-07-24 15:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0664
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Stransky 2008-05-19 19:02:22 EDT
Description of problem:

evolution28-cairo uses unsupported pixmap format CAIRO_FORMAT_RGB16_565 if X
server runs with 16-bit color depth.

This pixmap format is no longer supported by recent cairo which is embedded in
firefox 3. The incompatibility breaks printing from firefox on 16bpp desktops.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. set color depth to 16 bit 
2. run firefox-3 and try to print any web page which contains colored texts or
images
  
Actual results:

Nothing is printed.

Expected results:

Correct page.

Additional info:
Comment 1 RHEL Product and Program Management 2008-05-19 19:21:12 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Martin Stransky 2008-05-20 03:22:51 EDT
Ehm ehm, pm_ack-? Don't we care about broken printing?
Comment 3 RHEL Product and Program Management 2008-05-20 03:41:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 Matthew Barnes 2008-05-20 06:20:04 EDT
It's probably too late for 4.7.  I imagine QA is at capacity.
Comment 18 Martin Stransky 2008-05-27 05:02:10 EDT
Changed component to firefox. It has to be fixed there.

The problem is that firefox/cairo 1.6.4 tries to create to create the 16-bit
image surfaces what are not supported there.

It happens during the image optimalization in nsThebesImage::Optimize(). 

A workaround for 16-bit desktops is to set the MOZ_DISABLE_IMAGE_OPTIMIZE=1
shell variable.
Comment 24 errata-xmlrpc 2008-07-24 15:10:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0664.html

Note You need to log in before you can comment on or make changes to this bug.