Bug 447508 - No screen / Black screen after udev.
No screen / Black screen after udev.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 04:48 EDT by Steve
Modified: 2008-07-09 04:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 18:17:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
actual xorg.conf (954 bytes, text/plain)
2008-05-20 04:48 EDT, Steve
no flags Details
Xorg.0.log (41.11 KB, text/plain)
2008-05-21 03:27 EDT, Steve
no flags Details

  None (edit)
Description Steve 2008-05-20 04:48:25 EDT
Description of problem:
After successfully installing F9 and rebooting, the screen goes black after
udev. The card only works with the vesa driver. Neither the radeon nor the ati
driver works.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.8.0-14.fc9.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Black screen. Works only with vesa driver.

Expected results:
Should work with the ati driver.

Additional info:
Card is "Radeon 9800 Pro 256 AGP" Monitor is "BenQ FP202W"
Comment 1 Steve 2008-05-20 04:48:25 EDT
Created attachment 306089 [details]
actual xorg.conf
Comment 2 Steve 2008-05-20 04:57:03 EDT
Sorry for wrong information! The Card is "ATI Radeon X1650 256".
Comment 3 Steve 2008-05-20 05:44:03 EDT
I installed the radeonhd driver and it is working now. But why did anaconda
wrote "radeon" in the xorg.conf when the card is not supported? It he not supported?
Comment 4 Dave Airlie 2008-05-20 19:52:35 EDT
it should be supported can you switch back to radeon and attached a
/var/log/Xorg.0.log from it?

it might also be better to just remove xorg.conf and see what happens.
Comment 5 Steve 2008-05-21 03:27:31 EDT
I switched back to radeon --> Xorg.0.log.

After removing xorg.conf, the screen goes also black and no more xorg.conf will
be created.
Comment 6 Steve 2008-05-21 03:27:58 EDT
Created attachment 306220 [details]
Xorg.0.log
Comment 7 Steve 2008-07-09 04:35:48 EDT
It seems to be fixed with today's update, but i'm not sure because i have
another monitor now. can someone else confirm that?

Note You need to log in before you can comment on or make changes to this bug.