Bug 447528 - Paste when scrolling using mouse wheel
Paste when scrolling using mouse wheel
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 07:50 EDT by markm
Modified: 2018-04-11 05:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 20:56:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (718 bytes, text/plain)
2008-06-02 18:14 EDT, markm
no flags Details
xorg.conf created when x started without config (718 bytes, text/plain)
2008-06-02 18:22 EDT, markm
no flags Details
Log file from this start (x started without xorg.conf) (12.36 KB, text/plain)
2008-06-02 18:23 EDT, markm
no flags Details
Log file created when started with nv driver and no xorg.conf file (47.14 KB, text/plain)
2008-06-04 10:21 EDT, markm
no flags Details

  None (edit)
Description markm 2008-05-20 07:50:59 EDT
Description of problem:

When I scroll (in Eclipse, Firefox, Evolotion, OpenOffice...) it pastes randomly
my current clippoard - really annoying.

Version-Release number of selected component (if applicable):

current from fedora updates

How reproducible:

always

Steps to Reproduce:
1. open a document in any application
2. scroll it using mouse wheel

Actual results:

it randomly pastes current clipboard

Expected results:

nothing being pasted, just scrolling

Additional info:

is it any way to disable past on middle click? I've tried to google, but I've
found only information, that "it's not bug, it's a feature" - maybe it used to
be true for three button mouses without wheels, but when mouse is build with a
wheel/third button, it makes it really annoying feature.
Comment 1 Matěj Cepl 2008-06-02 18:07:47 EDT
> Version-Release number of selected component (if applicable):
> current from fedora updates

Please, is 'rpm -q xorg-x11-server-Xorg' that difficult?

Otherwise, please attach your X server config file (/etc/X11/xorg.conf) and X
server log file (/var/log/Xorg.*.log) to the bug report as individual
uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 markm 2008-06-02 18:13:49 EDT
[root@d620 ~]# rpm -q xorg-x11-server-Xorg
xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.i386
[root@d620 ~]# 
Comment 3 markm 2008-06-02 18:14:44 EDT
Created attachment 308104 [details]
xorg.conf
Comment 4 markm 2008-06-02 18:22:49 EDT
Created attachment 308131 [details]
xorg.conf created when x started without config
Comment 5 markm 2008-06-02 18:23:25 EDT
Created attachment 308135 [details]
Log file from this start (x started without xorg.conf)
Comment 6 markm 2008-06-02 18:28:24 EDT
if you need anything else, please let me know :)

Thanks in advance.
Comment 7 Matěj Cepl 2008-06-04 09:09:32 EDT
Given that I haven't ever met so bizarre thing elsewhere, I tend to blame nvidia
driver. Moreover, xorg as shipped in Fedora doesn't produce /etc/X11/xorg.conf
when run without it. Could you please reproduce this bug using only free
drviers? Otherwise I will have to close this bug as CANTFIX.
Comment 8 markm 2008-06-04 10:21:49 EDT
Created attachment 308344 [details]
Log file created when started with nv driver and no xorg.conf file
Comment 9 markm 2008-06-04 10:26:56 EDT
Unfortunately problem persists. Also, I have no choice - with a screen of
1680x1050 - nvidia proprietary driver is the only option I have (nv driver's
performance is worse then poor with this resolution).

so, when I scroll (using mouse wheel) accidentally and not intentionally my
current clipboard is being pasted in random places. changing a driver from
nvidia to nv (open source driver) does not solve this problem.

I have this problem on two different machines with two different mouses. Will
test this at home in Fedora 9 with nv driver, but guess, it will not help either.

Thanks in advance.
Comment 10 Peter Hutterer 2008-07-15 22:47:08 EDT
Marek: 
The two log files are from two different X server.
The one in Comment #8 is server 1.3 (F8), the one in Comment #5 is server
1.5-prerelease (F9).
Which server version are you running and which version experiences the problem?
Comment 11 markm 2008-07-16 02:43:55 EDT
as I wrote in comment #9, there are two different log files because I experience
the problem on two different machines with two different X servers.
Comment 12 Peter Hutterer 2008-07-16 03:48:45 EDT
let's look at the log supplied in #5.
You seem to have three devices, touchpad, a logitech wireless and some no-name
ps/2 mouse.

I guess both the logitech and ps/2 mouse have wheels. Does it happen with both,
or just one of the mice?

Also, since most mice have middle button as part of the wheel - is there a
chance that you're accidentally pressing too hard when scrolling, thus causing a
middle-click?

If so, you could try xmodmap -e "pointer = 1 6 3 4 5". This maps the middle
button to button 6, thus not causing paste events anymore. Of couse, you can
adjust that line to map it as far back as you want.
Comment 13 markm 2008-07-16 04:34:56 EDT
I am using a laptop computer, so by default I have a touchpad and a mouse. don't
know why there is another one in my log file - maybe because I was testing
different one?

while testing, both mice had wheels with button build in. it might be a problem
that I am pressing a wheel too hard while scrolling or the wheel is too sensitive.

remapping middle button to button 6 does not solve the problem because I still
want to use my middle button in firefox to open links in tabs. Firefox itself
allows to disable paste-on-middle click, which helps a lot. Unfortunately I
don't know how to disable that “feature” for my desktop.

As I said earlier, problem remains, I got used to it - but it strikes back from
time to time when I accidentally past something within eclipse - sometimes it is
easy to find, sometimes it takes me a while.
Comment 14 Peter Hutterer 2008-07-16 20:56:09 EDT
Sorry, will have to close this bug as CANTFIX.

From what I can tell, the spurious events seem to be a hardware issue (wheel to
sensitive).

The paste functionality is on a per-application/per-toolkit basis. You have to
hope that the apps provide an option to disable this feature, otherwise there
isn't much you can do.
Comment 15 markm 2008-07-17 04:59:27 EDT
I've tried different mice and as far as I can tell, each one had the same
problem. The easiest way would be to disable this 'paste-on-middle-click'
functionality, but I don't know how to do that. Eclipse developers said they
didn't want to add an option to disable that.

It's really sad - x server developers are not willing to make
'paste-on-middle-click' optional, eclipse developers don't want to make an
option to disable that, gnome's developers haven't responded to my request. And
I don't know how to write a daemon which will monitor mouse clicks and prevent
paste-on-middle-click.

Any ideas how to disable this 'paste-on-middle-click' in X server without
re-mapping buttons?

Thanks in advance.
Comment 16 Peter Hutterer 2008-07-17 19:43:42 EDT
This actually has nothing to do with the x server. All the x server does is send
a button 2 event, it's the client that does the rest. So the only option you
have for the server is to not make it send those events - by remapping the button.

Note You need to log in before you can comment on or make changes to this bug.