Bug 447536 - No IPv4 address after boot or network restart.
No IPv4 address after boot or network restart.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 431941 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 09:29 EDT by Jan ONDREJ
Modified: 2008-09-16 19:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 19:21:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2008-05-20 09:29:38 EDT
Description of problem:
I have no IPv4 address after boot of Fedora 9. I am using dhcp (dhclient) to get
IP addresses for my notebook.

Version-Release number of selected component (if applicable):
initscripts-8.76.2-1.i386
dhclient-4.0.0-15.fc9.i386

How reproducible:
Always, same for me and my colleague.

Steps to Reproduce:
1. boot fedora 9 with DHCP enabled
  
Actual results:
eth0      Link encap:Ethernet  HWaddr 00:03:0D:4D:78:00  
          inet6 addr: xxxx:4118:400:1:203:dff:fe4d:7800/64 Scope:Global
          inet6 addr: fe80::203:dff:fe4d:7800/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10362 errors:0 dropped:0 overruns:0 frame:0
          TX packets:288 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:716375 (699.5 KiB)  TX bytes:43707 (42.6 KiB)
          Interrupt:16 

Expected results:
Working IPv4 network.

Additional info:
/var/log/messages
May 20 15:22:00 note kernel: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
May 20 15:22:00 note dhclient: failed to set close-on-exec for
/var/lib/dhclient/dhclient-eth0.leases
May 20 15:22:01 note dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
May 20 15:22:01 note dhclient: DHCPACK from 158.197.xxx.1
May 20 15:22:01 note NET[9039]: /sbin/dhclient-script : updated /etc/resolv.conf
May 20 15:22:01 note dhclient: bound to 158.197.xxx.42 -- renewal in 10359 seconds.
May 20 15:22:01 note dhclient: failed to set close-on-exec for
/var/lib/dhclient/dhclient-wlan0.leases
May 20 15:22:01 note dhclient: Failed to get interface index: No such device
May 20 15:22:01 note dhclient: 
May 20 15:22:01 note dhclient: This version of ISC DHCP is based on the release
available
May 20 15:22:01 note dhclient: on ftp.isc.org.  Features have been added and
other changes
May 20 15:22:01 note dhclient: have been made to the base software release in
order to make
May 20 15:22:01 note dhclient: it work better with this distribution.
May 20 15:22:01 note dhclient: 
May 20 15:22:01 note dhclient: Please report for this software via the Red Hat
Bugzilla site:
May 20 15:22:01 note dhclient:     http://bugzilla.redhat.com
May 20 15:22:01 note dhclient: 
May 20 15:22:01 note dhclient: exiting.

My IP address is received properly, but next time dropped.

I can repair my IP address by killing and restarting dhclient process or just by
running another "dhclient -d eth0".

This behaviour is after updating to Fedora 9, on Fedora 8 there was no problems.

My ifcfg-eth0:
# Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:03:0D:4D:78:00
ONBOOT=yes
DHCP_HOSTNAME=note.salstar.sk
TYPE=Ethernet
USERCTL=yes
IPV6INIT=yes

# these 3-4 parameters are required to set my own DNS servers
PEERDNS=yes
RESOLV_MODS=yes
DNS1=127.0.0.1
#DNS2=158.197.16.31

SElinux is in permissive mode.
Comment 1 David Cantrell 2008-08-01 19:36:14 EDT
Can you configure the interface manually using ifconfig?  Does it work if you do that?
Comment 2 Jan ONDREJ 2008-08-04 03:06:23 EDT
I think this problem has been solved by latest updates (I am using updates-testing repository on my notebook).
Comment 3 David Cantrell 2008-08-04 15:56:27 EDT
Marking as MODIFIED since there is an update available now in updates-testing to address this issue.

Thank you.
Comment 4 David Cantrell 2008-08-04 16:10:09 EDT
*** Bug 431941 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2008-08-07 19:57:59 EDT
dhcp-4.0.0-17.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7105
Comment 6 Fedora Update System 2008-09-16 19:21:44 EDT
dhcp-4.0.0-17.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.