Bug 447594 - audio going through pulseaudio causes skipping, dies
audio going through pulseaudio causes skipping, dies
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 14:13 EDT by Brian Johnson
Modified: 2009-02-24 22:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 22:51:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Johnson 2008-05-20 14:13:12 EDT
Description of problem: When listening to streaming audio through
rhythmbox,amarok (ultimately going through pulseaudio), there are skips in the
audio. Listening to last.fm through rhythmbox,amarok leads to skipping, then
choppy sound, and finally it quits until the next song.


Version-Release number of selected component (if applicable): pulseaudio
0.9.10-1.fc9


How reproducible: consistent


Steps to Reproduce:
1. make sure pulseaudio and alsa-plugins-pulseaudio are installed, start
rhythmbox or amarok
2. begin listening to streaming media. I've used
http://stream.streamingradioguide.com/listens.php?stationid=1419 and the last.fm
plugin in rhythmbox and last.fm and some shoutcast streams in amarok.
  
Actual results: with the streamingradioguide (rhythmbox) and shoutcast stream
(amarok), there are skips in the audio. With last.fm clients (rhythmbox, amarok,
last.fm client for linux), there are skips, then audio becomes choppy, and
finally just dies until the next song.


Expected results: smooth, uninterrupted audio bliss


Additional info: All appropriate codecs installed to play the formats being
streamed (mp3 primarily). Confirmed that this appears to be a pulseaudio problem
by completely uninstalling pulseaudio. Audio now works as it should, no
interruptions or skips.
Comment 1 Brian Johnson 2008-05-20 14:21:11 EDT
OH! One more thing...if I remember correctly, listening to music on my harddrive
does not seem to be affected by the problem, sounds normal and audio uninterrupted 
Comment 2 antonio montagnani 2008-05-29 10:08:43 EDT
I removed pulseaudio 0.9.10-1.fc9 and everything worked again.
Please note that I had terrible quality also from files from my hard disk,
skipping and then sound was dead.
I experienced many breaks on radio streams and then streams died.
In the meantime I suggest to have a look also to Bugzilla Bug 446192: horrible
skipping audio, that may not be connected to this bug...
Comment 3 Lennart Poettering 2008-12-18 09:28:12 EST
Are you using any closed source drivers such as nvidia or ati fglrx?

Have you tried to enable RT scheduling for PA?
Comment 4 Lennart Poettering 2009-02-24 22:51:34 EST
Closing due to lack of response.

Note You need to log in before you can comment on or make changes to this bug.