This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 447603 - pygame lacks support for some modules on x86_64
pygame lacks support for some modules on x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pygame (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Christopher Stone
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 14:55 EDT by Björn Petersen
Modified: 2008-06-03 03:31 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.7.1-17.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 03:31:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch-file (401 bytes, patch)
2008-05-20 14:55 EDT, Björn Petersen
no flags Details | Diff

  None (edit)
Description Björn Petersen 2008-05-20 14:55:02 EDT
Description of problem:
On an x86_64 system pygame package lacks support of some modules, i.e. font.

Version-Release number of selected component (if applicable):
pygame-1.7.1-16.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install pygame on an x86_64
2. Try to run a program that need pygame.font (In my case I try to run freevo)
  
Actual results:
Starting freevo gives error:
/usr/lib/python2.5/site-packages/freevo/osd.py:367: RuntimeWarning: use font: No
module named font
  pygame.font.init()

Expected results:
Normal run.

Additional info:

Hello,

trying to run freevo on f9, which uses pygame, give error about
pygame.font missing (use font: No module named font).
Looking in the pygame-package for x86_64, I can't found the font.so
file which can be found in the i386 package.
I think the error is in the config_unix.py file found in source of
pygame. Line 14 should be changed to origlibdirs = ['/lib','/lib64']
so that the config looks for lib-files in both, i386 and x86_64 dir.
(See attached patch-file).
It seems that the SDL_ttf-devel package for x86_64 changed from
Fedora 8 to 9, because in f8 if you have installed the SDL_ttf x86_64 package,
libs were installed in both, /usr/lib and /usr/lib64.
So, another possible solution is to change the SDL_ttf-devel package for
x86_64 to install both libs, for i386 and x86_64 as it was in f8 and
than recompile pygame.

Thank you for your time.

Björn
Comment 1 Björn Petersen 2008-05-20 14:55:02 EDT
Created attachment 306164 [details]
patch-file
Comment 2 Fedora Update System 2008-05-22 15:00:20 EDT
pygame-1.7.1-17.fc9 has been submitted as an update for Fedora 9
Comment 3 Björn Petersen 2008-05-27 15:31:32 EDT
Hello,

trying pygame-1.7.1-17 from Fedora Update System now works on my x86_64
Fedora 9 system.
The missing modules are installed and freevo run normal.

Thanks a lot!

Björn
Comment 4 Marcos Martins da Silva 2008-05-27 19:07:34 EDT
Please, from where can I download pygame-1.7.1-17.fc9? I have searched F9
repositories with no success.
Comment 5 Björn Petersen 2008-05-28 06:21:01 EDT
Hi,

I downloaded the version from Fedora Update System at
https://admin.fedoraproject.org/updates/F9/pending/pygame-1.7.1-17.fc9
Don't know if this is the correct way, or if we have to wait for offical release.
( This is my first bug report ;-) )

Björn
Comment 6 Christopher Stone 2008-05-28 09:53:26 EDT
Hi, you should be able to download it like so:

yum --enablerepo=updates-testing update pygame

I'll move it over to the regular updates repo soon.
Comment 7 Marcos Martins da Silva 2008-05-28 19:21:16 EDT
Thank you all. Monsterz works perfectly now. This bug seems solved for me.
Comment 8 Fedora Update System 2008-05-28 22:34:51 EDT
pygame-1.7.1-17.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pygame'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4406
Comment 9 Fedora Update System 2008-06-03 03:31:26 EDT
pygame-1.7.1-17.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.