Bug 447628 - Stale NFS file handle errors on readonly automounted directories [NEEDINFO]
Stale NFS file handle errors on readonly automounted directories
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 17:22 EDT by Matt Dey
Modified: 2014-06-02 09:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:18:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
steved: needinfo? (matt.dey)
pm-rhel: needinfo? (matt.dey)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 201211 None None None Never

  None (edit)
Description Matt Dey 2008-05-20 17:22:04 EDT
Description of problem:  NFS error handeling.


Version-Release number of selected component (if applicable):


How reproducible: Almost always


Steps to Reproduce:
1. Mount a readonly NFS Filesyetm from a NetApp appliance
2. attempt to create a direoctory or touch a file in the RO filesystem
3.
  
Actual results: The directory the operation was attempted in will become stale.
 Returning the error "Stale NFS file handle"\


eg..

[/net/nasa04/vol/fast/fastbio/SecMap]
matt@unixdeva09$ ls -la
total 16
drwxr-xr-x  4 fastbio vision 4096 May 20 15:21 .
drwxr-xr-x 18 fastbio vision 4096 May 10 09:02 ..
drwxr-xr-x 13 fastbio vision 4096 Jan  4  2007 localvision
drwxr-xr-x  3 fastbio vision 4096 Jul  1  2005 releases

[/net/nasa04/vol/fast/fastbio/SecMap]
matt@unixdeva09$ touch junk
touch: cannot touch `junk': Read-only file system

[/net/nasa04/vol/fast/fastbio/SecMap]
matt@unixdeva09$ ls -la
ls: .: Stale NFS file handle

The error does not occur on RHEL4 boxes.

Expected results: Not a stale NFS file handle.


Additional info: Appears to be the same as bug 201211 Filed against Fedora.
Comment 1 Steve Dickson 2008-05-21 09:37:54 EDT
What is the server that this is happening with and 
how reproducible is it? 
Comment 2 Matt Dey 2008-05-21 09:57:44 EDT
This is happening with a Netapp NFS server and is easily reproducible. 
Comment 3 Steve Dickson 2008-05-30 15:43:42 EDT
Can we get a bzip2 tshark network trace of this? Something similar
to 'tshark -w /tmp/bz447628.pcap host <server> ; bzip2 /tmp/bz447628.pcap'

Comment 4 RHEL Product and Program Management 2014-03-07 07:14:25 EST
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in the  last planned RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX. To request that Red Hat re-consider this request, please re-open the bugzilla via  appropriate support channels and provide additional business and/or technical details about its importance to you.
Comment 5 RHEL Product and Program Management 2014-06-02 09:18:25 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.