Bug 447653 - BuildRequires needs to be "sed"; not "/bin/sed"
BuildRequires needs to be "sed"; not "/bin/sed"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 19:41 EDT by Jason Farrell
Modified: 2008-05-21 19:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 20:00:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2008-05-20 19:41:58 EDT
"yum-builddep xchat-2.8.4-15.fc9.src.rpm" fails with error "Error: No Package
found for /bin/sed"

the BuildRequires line in the spec needs to be just 'sed', then it yanks in all
deps as expected
Comment 1 Kevin Kofler 2008-05-20 20:00:22 EDT
You're using a broken build of yum which chokes on file dependencies (like the 
one which reported the bogus "broken dependencies" in Rawhide). A BuildRequires 
on a file is perfectly valid, and the file /bin/sed is contained in the sed 
package.
Comment 2 Jason Farrell 2008-05-21 19:07:14 EDT
yeah, thanks, this was fixed in yum-3.2.16-2.fc9.noarch

Note You need to log in before you can comment on or make changes to this bug.