Bug 447664 - uudeview fails to decode any files: "Write error on target file"
uudeview fails to decode any files: "Write error on target file"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: uudeview (Show other bugs)
9
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 21:58 EDT by Pavel Roskin
Modified: 2008-06-14 00:17 EDT (History)
0 users

See Also:
Fixed In Version: 0.5.20-17.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-14 00:17:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test file (200 bytes, text/plain)
2008-05-20 21:58 EDT, Pavel Roskin
no flags Details

  None (edit)
Description Pavel Roskin 2008-05-20 21:58:11 EDT
Description of problem:
uudeview fails to decode any files

Version-Release number of selected component (if applicable):
uudeview-0.5.20-15

How reproducible:
Always

Steps to Reproduce:
1. uudeview foo.enc
  
Actual results:
$ uudeview foo.enc 
Loaded from foo.enc: '' (foo): foo part 1   Text
                                                                      
Found 'foo' State 16 Text Parts OK

  -rw-r--r-- foo             is OK   [d] (?=help) y
ERROR: Write error on target file uudeview.tmp.VuzNiI: File exists
ERROR: while decoding foo (foo): File I/O Error
0 files decoded from 1 input file, 1 failed                           

Expected results:
$ /home/proski/src/uudeview-0.5.20/unix/uudeview foo.enc 
Loaded from foo.enc: '' (foo): foo part 1   Text
                                                                      
Found 'foo' State 16 Text Parts OK

  -rw-r--r-- foo             is OK   [d] (?=help) y
    File successfully written to /home/proski/tmp/uude/foo            
1 file decoded from 1 input file, 0 failed                            

Additional info:
The standard uudeview-0.5.20 compiled from the sources doesn't have this
problem.  It's a Fedora specific problem, likely due to an incorrect security patch.

I'm giving it the highest severity because it's the primary function of uudeview
to decode files, and it fails at it every time, and there is no workaround I
could devise by trying all options.
Comment 1 Pavel Roskin 2008-05-20 21:58:11 EDT
Created attachment 306199 [details]
test file
Comment 2 Adrian Reber 2008-05-24 05:44:00 EDT
I was away a few days. I will look into it in the next days.
Comment 3 Fedora Update System 2008-06-11 05:06:43 EDT
uudeview-0.5.20-17.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-06-11 19:34:33 EDT
uudeview-0.5.20-17.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update uudeview'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5242
Comment 5 Pavel Roskin 2008-06-12 12:20:22 EDT
The testing version is working, thanks!
Comment 6 Fedora Update System 2008-06-14 00:17:46 EDT
uudeview-0.5.20-17.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.