Bug 447670 - Everything tree lacks images/, is not installable
Everything tree lacks images/, is not installable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 22:48 EDT by Matt Domsch
Modified: 2014-03-16 23:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 18:12:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2008-05-20 22:48:53 EDT
Description of problem:
The Everything tree does not have the images/ directory that the Fedora tree
has.  This makes Everything unusable for installation purposes.

In a PXE + NFS scenario, what I would like to do is (notice the method=):

PXE Config:
label builder-x86-64
        kernel /pxelinux.cfg/fedora/vmlinuz.f9.x86_64
        append initrd=/pxelinux.cfg/fedora/initrd.img.f9.x86_64 root=/dev/ram/0
ramdisk_size=8192 DEBUG=0
method=nfs:server:/var/ftp/pub/Distros/RedHat/fedora/linux/releases/9/Everything/x86_64/os
ks=http://myserver/ks.cfg ksdevice=eth0

so it would use the Everything tree.  However, this fails, as images/stage2.img
is not present here.

Instead, I must install as such (again notice method=):

PXE Config:
label builder-x86-64
        kernel /pxelinux.cfg/fedora/vmlinuz.f9.x86_64
        append initrd=/pxelinux.cfg/fedora/initrd.img.f9.x86_64 root=/dev/ram/0
ramdisk_size=8192 DEBUG=0
method=nfs:server:/var/ftp/pub/Distros/RedHat/fedora/linux/releases/9/Fedora/x86_64/os
ks=http://myserver/ks.cfg ksdevice=eth0

and ks.cfg must also contain:
repo --name=fedora-9
--baseurl=http://myserver/pub/fedora/linux/releases/9/Everything/x86_64/os

so the package selection can use the Everything tree.

I just find this odd.  Now my ks.cfg file is no longer version agnostic like it
was before.

If we hardlinked Fedora/$arch/os/images  into Everything/$arch/os/images  then
the Everything tree would be directly installable because stage2.img would be
available to it.

Something to consider for F10.

Version-Release number of selected component (if applicable):
Fedora 8 and 9 at least.
Comment 1 Jeremy Katz 2008-05-20 23:15:48 EDT
Add stage2= pointing to the stage2 image and then method= can point to the
Everything tree.  For F10, hopefully we'll finish getting this dichotomy
straightened out and we'll have
* stage2= to point to where to find stage2
* repo= to point to where to find a repo of packages
* method= being deprecated long-term and not the recommended way of doing anything

And then it will be a glorious day :-)
Comment 2 Chris Lumens 2008-06-18 11:11:02 EDT
This is now the case.  You can have stage2=<path to stage2> repo=http://whatever
in your pxeboot args.  Please give it a test with the next build of anaconda in
Rawhide and let me know how well it's working for you.
Comment 3 Matt Domsch 2008-08-06 18:12:45 EDT
works for me  now in rawhide, thanks!

Note You need to log in before you can comment on or make changes to this bug.