Bug 447678 - Cannot use gnupg 1.x keyring in gnupg2
Cannot use gnupg 1.x keyring in gnupg2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnupg2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 00:49 EDT by Shawn Starr
Modified: 2008-06-03 11:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 11:45:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Starr 2008-05-21 00:49:22 EDT
Description of problem:
While trying to list my keys with gpg2 I get a fatal error from gpg2.

Version-Release number of selected component (if applicable):
gnupg2-2.0.9-1.fc9.i386
libgcrypt-1.4.0-3.i386

How reproducible:
100% of time only with gpg2

Steps to Reproduce:
1. run gpg2 --list-keys
2. observe failure
  
Actual results:

pub   1024D/XXXXXXXXX 2004-02-11
uid                  XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
uid                  XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
uid                  XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
uid                  XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
uid                  [jpeg image of size 5004]
sub   1024g/XXXXXXXXX 2004-02-111

an mpi of size 0 is not allowed
an mpi of size 0 is not allowed
gpg: keyring_get_keyblock: read error: Invalid packet
gpg: keydb_get_keyblock failed: Invalid keyring


Expected results:

gpg2 should display all keys successfully.

Additional info:
Does not occur with gpg1, shows all keys properly.

This is a problem in GNOME seahorse because it causes gpg2 to get pegged at 100%
CPU. Breaks any GNOME keyring tools that allow you to adjust keys. I believe
they all use gpg2 by default for key management now.

This is for Fedora 9 and Rawhide (f10-devel)
Comment 1 Shawn Starr 2008-05-21 00:53:10 EDT
kgpg does not experience this problem when its using gpg 1.x
Comment 2 Rex Dieter 2008-05-21 07:41:26 EDT
works fine here, I'd guess it may be something specific to your keyring, your 
config, or seahorse (since it uses it's own agent instead of gnupg2's 
gpg-agent).

Please report this upstream to
https://bugs.g10code.com/gnupg/index
Comment 3 Rex Dieter 2008-06-02 08:18:06 EDT
Fwiw, gnupg2 is more strict and less permissive when it comes to keyrings, my
guess is that's what's going on here.

Otherwise, have you checked yet with upstream?  maybe try posting to
http://lists.gnupg.org/mailman/listinfo/gnupg-users
Comment 4 Rex Dieter 2008-06-03 11:45:50 EDT
confirmed invalid keys the culprit.

Note You need to log in before you can comment on or make changes to this bug.