Bug 447694 - Wine triggers kernel hard-lock
Wine triggers kernel hard-lock
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
http://www.fedoraforum.org/forum/show...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 03:38 EDT by Paul Bredbury
Modified: 2008-05-28 06:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:47:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Bredbury 2008-05-21 03:38:29 EDT
Hi, the kernel (2.6.25.3-18.fc9.x86_64) is hard-locking, which does not occur in
vanilla 2.6.25.4 - this is triggered by Wine.

My kernel is tainted with nvidia 173.08 module.

Fixed by:

$ diff -u kernel.spec kernel.spec-brebs 
--- kernel.spec	2008-05-13 09:17:39.000000000 +0100
+++ kernel.spec-brebs	2008-05-21 08:34:48.000000000 +0100
@@ -31,7 +31,7 @@
 ## If this is a released kernel ##
 %if 0%{?released_kernel}
 # Do we have a 2.6.21.y update to apply?
-%define stable_update 3
+%define stable_update 4
 # Set rpm version accordingly
 %if 0%{?stable_update}
 %define stablerev .%{stable_update}
@@ -107,7 +107,8 @@
 
 # Want to build a vanilla kernel build without any non-upstream patches?
 # (well, almost none, we need nonintconfig for build purposes). Default to 0 (off).
-%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
+#%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
+%define with_vanilla 1
 
 # pkg_release is what we'll fill in for the rpm Release: field
 %if 0%{?released_kernel}
Comment 1 Dave Jones 2008-05-21 10:47:09 EDT
we can't debug situations where the nvidia module has been loaded due to the
absence of source.
Comment 2 Chuck Ebbert 2008-05-27 16:58:39 EDT
(In reply to comment #0)
> Fixed by:
> 
> --- kernel.spec	2008-05-13 09:17:39.000000000 +0100
> +++ kernel.spec-brebs	2008-05-21 08:34:48.000000000 +0100
> @@ -31,7 +31,7 @@
>  ## If this is a released kernel ##
>  %if 0%{?released_kernel}
>  # Do we have a 2.6.21.y update to apply?
> -%define stable_update 3
> +%define stable_update 4
>  # Set rpm version accordingly
>  %if 0%{?stable_update}
>  %define stablerev .%{stable_update}
> @@ -107,7 +107,8 @@
>  
>  # Want to build a vanilla kernel build without any non-upstream patches?
>  # (well, almost none, we need nonintconfig for build purposes). Default to 0
(off).
> -%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
> +#%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
> +%define with_vanilla 1
>  
>  # pkg_release is what we'll fill in for the rpm Release: field
>  %if 0%{?released_kernel}

Uh, you can just add "--with vanilla" to the rpmbuild command instead of
patching the spec.

And did you load the nvidia module in your vanilla kernel when you tested?

Comment 3 Paul Bredbury 2008-05-28 04:01:07 EDT
Yes.

I just re-ran ies4linux, and the hard lock still occurs after a minute or two with:

$ uname -a
Linux brebslinux 2.6.25.4-30.fc9.x86_64 #1 SMP Wed May 21 17:34:18 EDT 2008
x86_64 x86_64 x86_64 GNU/Linux

I'll try http://koji.fedoraproject.org/koji/buildinfo?buildID=50712 when it is
available.
Comment 4 Paul Bredbury 2008-05-28 06:07:30 EDT
Hooray, fixed with:

$ uname -a
Linux brebslinux 2.6.25.4-38.fc9.x86_64 #1 SMP Wed May 28 01:43:41 EDT 2008
x86_64 x86_64 x86_64 GNU/Linux

Note You need to log in before you can comment on or make changes to this bug.