Bug 447697 - Epiphany cannot use correctly the mime info and relate it to installed applications
Epiphany cannot use correctly the mime info and relate it to installed applic...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 04:04 EDT by Peter Janakiev
Modified: 2008-06-18 16:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-18 16:24:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Epiphany unable to recognize the application (20.48 KB, image/png)
2008-05-25 15:40 EDT, Peter Janakiev
no flags Details

  None (edit)
Description Peter Janakiev 2008-05-21 04:04:11 EDT
Description of problem:
When the automatically download and open option in epiphany is enabled it is
supposed to automatically download a file when clicked on and open it with the
application as per the user preferences in nautilus. This does not work for
torrent files. 
If we right click on a torrent file on the local disk and see the tab "Open
with" we see Deluge is selected as application to open those mime type. then we
click on such file in Nautilus and it is opened in deluge. But when we click on
a link in the Internet that is to a torrent file a windows pops up asking if it
should download this file. It says the file type is BitTorrent and says I don't
have an application that can open this file and offers me to download it instead.


Version-Release number of selected component (if applicable):
epiphany-2.22.1.1-1.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Start epiphany
2. navigate to a web site with links to torrent files
3. click on a torrent file link
  
Actual results:
Epiphany asks me if it should download the file and says it does not know of an
application that can open it

Expected results:
Epiphany should correctly recognize that this file is to be opened with deluge
and use it.

Additional info:
I submit this as epiphany bug because in nautilus the mime is correctly linked
to deluge
Comment 1 Peter Janakiev 2008-05-23 03:51:45 EDT
Actually it seem to be more than I thought. 
Epiphany cannot open anything, jpeg,pdf, whatever, it's like it completely does
not know about the mime types and supporting apps.

Hope this helps
Comment 2 Peter Janakiev 2008-05-25 15:40:39 EDT
Created attachment 306627 [details]
Epiphany unable to recognize the application

Any one able to reproduce it?
1. Open Epiphany and go to the fedora web page
2. Go to get fedora and select to click on torrent link
 You get this (attached) instead of actually downloading the torrent and load
it in Transmission/Deluge
Comment 3 Matěj Cepl 2008-05-26 11:07:14 EDT
I can reproduce very well with epiphany.i386 0:2.22.1.1-1.fc9 -- epiphany tries
to open .torrent file as text file and fill the window with binary junk.
Comment 4 Peter Janakiev 2008-06-17 15:18:10 EDT
It seem that this was due to some thing left in $HOME from previous versions, i
cannot duplicate it on a fresh install/new user (on x86_64).
Comment 5 Matěj Cepl 2008-06-18 16:24:57 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.